Bug 1849936 - perl-re-engine-PCRE2-0.16-5.fc33 FTBFS with Perl 5.32: t/s.t crashes
Summary: perl-re-engine-PCRE2-0.16-5.fc33 FTBFS with Perl 5.32: t/s.t crashes
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-re-engine-PCRE2
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://koji.fedoraproject.org/koji/t...
Whiteboard:
: 1852233 1864520 (view as bug list)
Depends On:
Blocks: F33FTBFS F33FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2020-06-23 08:41 UTC by Petr Pisar
Modified: 2020-08-04 10:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-03 09:33:37 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github rurban re-engine-PCRE2 issues 37 None open t/s.t fails and crashes with Perl 5.32.0 randomly 2020-08-03 09:27:44 UTC

Description Petr Pisar 2020-06-23 08:41:23 UTC
t/s.t fails or crashes with Perl 5.32.0 randomly:

$ while (perl -Mblib t/s.t); do :; done
1..10
ok 1 - s/a//; 'ab' => 'b'
ok 2 - s/.//g; 'abc' => ''
ok 3 - s/.//g; 'abcd' => ''
ok 4 - s/.//g; 'abcdefg' => ''
ok 5 - s/..//g; 'aabbc' => 'c'
ok 6 - s/./1+1/eg; 'a' => '2'
ok 7 - s/./1+1/eg; 'abc' => '222'
ok 8 - s/(.)/$1+1/eg; '3' => '4'
ok 9 - s/(.)/$1+1/eg; '123' => '234'
ok 10 - s/([0-9]+)/$1*2/e; 'abc123xyz' => ''abc246xyz'
1..10
ok 1 - s/a//; 'ab' => 'b'
ok 2 - s/.//g; 'abc' => ''
ok 3 - s/.//g; 'abcd' => ''
ok 4 - s/.//g; 'abcdefg' => ''
ok 5 - s/..//g; 'aabbc' => 'c'
ok 6 - s/./1+1/eg; 'a' => '2'
ok 7 - s/./1+1/eg; 'abc' => '222'
ok 8 - s/(.)/$1+1/eg; '3' => '4'
ok 9 - s/(.)/$1+1/eg; '123' => '234'
ok 10 - s/([0-9]+)/$1*2/e; 'abc123xyz' => ''abc246xyz'
free(): invalid pointer
Aborted (core dumped)

Comment 1 Petr Pisar 2020-06-30 07:18:05 UTC
*** Bug 1852233 has been marked as a duplicate of this bug. ***

Comment 2 Petr Pisar 2020-08-03 09:33:37 UTC
This is caused either by a regression in Perl 5.32.0 or there this packages misuses the regexp plugin interface. Upstream is unable to fix it.

This package was removed from Fedora 33.

Comment 3 Petr Pisar 2020-08-04 10:02:20 UTC
*** Bug 1864520 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.