Bug 1849952 - [csi-driver-manila-operator] There is no status for ManilaDriver
Summary: [csi-driver-manila-operator] There is no status for ManilaDriver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Mike Fedosin
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-23 09:21 UTC by Wei Duan
Modified: 2020-10-27 16:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:08:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
ManilaDriver_status (146.50 KB, image/png)
2020-06-23 09:21 UTC, Wei Duan
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:09:01 UTC

Description Wei Duan 2020-06-23 09:21:12 UTC
Created attachment 1698415 [details]
ManilaDriver_status

Description of problem:
After installing Maniladriver, there is no status displayed in web console page, seems there is no Maniladriver.status.conditions field in Maniladriver API.
This status will help user knows the current status. 

Version-Release number of selected component (if applicable):
[wduan@MINT config]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-06-20-194346   True        False         25h     Cluster version is 4.5.0-0.nightly-2020-06-20-194346

[wduan@MINT verification-tests]$ oc  get csv
NAME                                DISPLAY                      VERSION   REPLACES   PHASE
manila-csi-driver-operator.v4.5.0   Manila CSI Driver Operator   4.5.0                Succeeded


How reproducible:
Always

Steps to Reproduce:
From web console:
1. Install manila-csi-driver-operator
2. Install Maniladriver
From CLI
3. $ oc describe ManilaDriver cluster 

Actual results:
There is no status for Maniladriver in web console

[wduan@MINT verification-tests]$ oc get ManilaDriver cluster -o yaml
apiVersion: csi.openshift.io/v1alpha1
kind: ManilaDriver
metadata:
  creationTimestamp: "2020-06-23T08:16:36Z"
  finalizers:
  - finalizer.manila.csi.openshift.io
  generation: 2
  name: cluster
  resourceVersion: "1016353"
  selfLink: /apis/csi.openshift.io/v1alpha1/maniladrivers/cluster
  uid: d9245e24-19f0-4006-9d0a-2199612caf68
spec: {}

[wduan@MINT verification-tests]$ oc describe ManilaDriver cluster
Name:         cluster
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  csi.openshift.io/v1alpha1
Kind:         ManilaDriver
Metadata:
  Creation Timestamp:  2020-06-23T08:16:36Z
  Finalizers:
    finalizer.manila.csi.openshift.io
  Generation:        2
  Resource Version:  1016353
  Self Link:         /apis/csi.openshift.io/v1alpha1/maniladrivers/cluster
  UID:               d9245e24-19f0-4006-9d0a-2199612caf68
Spec:
Events:  <none>

Expected results:
There should be status display to let user know the ManialaDriver current status 

Master Log:

Node Log (of failed PODs):

PV Dump:
  
PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:
See attached snapshot

Comment 3 Jan Safranek 2020-06-23 13:59:12 UTC
This will get fixed by using CSI driver operator lib.

Comment 4 Jan Safranek 2020-07-31 10:23:14 UTC
This has been fixed by reworking it to library-go and ClusterCSIDriver CRD.

Comment 7 Qin Ping 2020-08-07 08:34:44 UTC
Verified with: 4.6.0-0.nightly-2020-08-06-225752

$ oc get clustercsidriver  manila.csi.openstack.org -ojson|jq .status
{
  "conditions": [
    {
      "lastTransitionTime": "2020-08-07T06:06:54Z",
      "reason": "AsExpected",
      "status": "False",
      "type": "SecretSyncDegraded"
    },
    {
      "lastTransitionTime": "2020-08-07T06:06:54Z",
      "status": "True",
      "type": "ManilaControllerAvailable"
    },
    {
      "lastTransitionTime": "2020-08-07T06:06:54Z",
      "reason": "AsExpected",
      "status": "False",
      "type": "ManilaDriverCredentialsDegraded"
    },
...
...

Comment 9 errata-xmlrpc 2020-10-27 16:08:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.