Bug 1850240 - Fix the resource alignment test for topology manager
Summary: Fix the resource alignment test for topology manager
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.z
Assignee: Francesco Romani
QA Contact: Walid A.
URL:
Whiteboard:
Depends On: 1850140
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-23 19:20 UTC by OpenShift BugZilla Robot
Modified: 2020-09-21 17:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-21 17:42:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 25195 None closed [release-4.5] Bug 1850240: tests: extended: fix TM regression test 2020-09-21 17:45:32 UTC
Red Hat Product Errata RHBA-2020:3719 None None None 2020-09-21 17:42:21 UTC

Description OpenShift BugZilla Robot 2020-06-23 19:20:02 UTC
+++ This bug was initially created as a clone of Bug #1850140 +++

Description of problem:
a specific test fails to capture this leading to false negatives

The existing regression test which wants to cover against regressions
on RHBZ#1813567 is actually doing the reverse check than it should.
We noticed after having the test run for few days on environment kindly
provided by nfvpe team.
The likely cause of why this mistake sneaked in is that I wrongly
configured the original environment on which I tried the test.

This patch fixes the issue and puts extra care in documenting and
checking the intent of the original bugzilla.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 13 Walid A. 2020-09-17 13:35:20 UTC
This was verified on 4.5.3 baremetal OCP install.

Comment 14 Walid A. 2020-09-17 13:35:35 UTC
This was verified on 4.5.3 baremetal OCP install.

Comment 16 errata-xmlrpc 2020-09-21 17:42:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3719


Note You need to log in before you can comment on or make changes to this bug.