Bug 1850438 - No "Not available" for VM network Utilization
Summary: No "Not available" for VM network Utilization
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Yaacov Zamir
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-24 10:19 UTC by Guohua Ouyang
Modified: 2020-10-27 16:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: network utilization data is an array of arrays, when no data available we get an empty array of arrays. Consequence: the component see an empty array of arrays as valid data. Fix: check for empty array of arrays in this case. Result: empty array of arrays is interpreted as no data.
Clone Of:
Environment:
Last Closed: 2020-10-27 16:09:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5816 0 None closed Bug 1850438: Check for empty multidata list 2020-06-29 08:50:15 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:09:28 UTC

Description Guohua Ouyang 2020-06-24 10:19:45 UTC
Description of problem:
Create a VM and visit VM overview page, there are "Not available" for other metrics but not for network, start the VM and "Not available" displayed for network immediately.

Version-Release number of selected component (if applicable):
4.5.0-rc.2 and master

How reproducible:
100%

Steps to Reproduce:
1. Create a VM with status off
2. Visit network Utilization in overview.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yaacov Zamir 2020-06-24 12:13:05 UTC
Ref: https://github.com/openshift/console/blob/master/frontend/packages/console-shared/src/components/dashboard/utilization-card/UtilizationItem.tsx#L84

the check: `data.every((datum) => datum.length)` return true for `data.length === 0` but we actually want also to cover `length === 0` as no data (e.g. false)

Comment 4 Guohua Ouyang 2020-06-30 09:54:40 UTC
verified on upstream 4.6 branch.

Comment 6 errata-xmlrpc 2020-10-27 16:09:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.