Bug 1850513 - VM that is being imported can be started but not stopped
Summary: VM that is being imported can be started but not stopped
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Phillip Bailey
QA Contact: Nandini Chandra
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-24 12:34 UTC by Radim Hrazdil
Modified: 2020-10-27 16:09 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:09:34 UTC
Target Upstream Version:


Attachments (Terms of Use)
video sample (1.63 MB, application/x-matroska)
2020-06-24 12:34 UTC, Radim Hrazdil
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6121 0 None closed Bug 1850513: Disable stop action in VM menu for in process CDI imports 2020-10-15 12:13:51 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:09:37 UTC

Description Radim Hrazdil 2020-06-24 12:34:40 UTC
Created attachment 1698590 [details]
video sample

Description of problem:
When a VM is being imported, it is possible to 'mark' the VM for start using the dropdown Start Virtual Machine action button.

But when the user decides to stop the VM, there is an error displayed that the VM is not running.


Version-Release number of selected component (if applicable):
4.6
CNV 2.4

How reproducible:
100%

Steps to Reproduce:
1. Create VM that needs to be imported
2. Start the VM while importing
3. Stop the VM while importing

Actual results:
Error

Expected results:
VM should finish import and remain stopped afther that

Additional info:

Comment 1 Tomas Jelinek 2020-07-10 05:49:46 UTC
this is actively being worked on, should converge in upcoming sprint

Comment 2 Phillip Bailey 2020-07-16 19:50:20 UTC
Per a conversation with Stu, it was a deliberate decision to not allow the user to ask for an invalid action such as stopping a VM that isn't running. The easiest solution would be to remove the stop action from the menu while the VM is importing. Stu recommended removing both the start and stop actions since both are technically invalid. The only concern I have with that is that the user is able to set the VM to start from the wizard, making it clear that it can be done. Stu also had the idea to gray out unavailable actions and add tooltips to explain why they aren't available. This would most likely clutter the menu too much, but I wanted to make sure the suggestion gets due consideration.

@Matt, thoughts?

Comment 3 Matt 2020-07-21 12:13:16 UTC
I wouldn't suggest a tooltip in the dropdown (it's not a pattern in the console that I'm aware of).
I think we can disable (but not remove) the actions that aren't available during the import. I believe a user who is importing a VM would be intuitive enough to understand that if it's importing you can't use it yet.
We do something similar in our designs for cloning a VM. Once the clone starts the VM actions are disabled (with the exception of cancelling the clone).

Comment 6 Guohua Ouyang 2020-09-15 06:43:25 UTC
verified on master

Comment 8 errata-xmlrpc 2020-10-27 16:09:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.