Bug 1850546 - ppc64le & s390x Operators filtered in Operator Hub
Summary: ppc64le & s390x Operators filtered in Operator Hub
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.6
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Evan Cordell
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks: 1855312
TreeView+ depends on / blocked
 
Reported: 2020-06-24 13:27 UTC by Andy McCrae
Modified: 2020-10-27 16:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1855312 1855316 1855322 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:08:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-logging-operator pull 575 0 None closed Bug 1850546: Add support label for s390x & ppc64le 2021-02-16 15:55:07 UTC
Github openshift cluster-nfd-operator pull 87 0 None closed Bug 1850546: Add support label for s390x & ppc64le 2021-02-16 15:55:07 UTC
Github openshift elasticsearch-operator pull 406 0 None closed Bug 1850546: Add support label for s390x & ppc64le 2021-02-16 15:55:06 UTC
Red Hat Knowledge Base (Solution) 5312831 0 None None None 2020-08-20 17:58:03 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:09:16 UTC

Description Andy McCrae 2020-06-24 13:27:59 UTC
Description of problem:

Since BZ #1796078 has gone live - the operators that are built and support additional architectures to x86_64 don't show up in OperatorHub because they are missing a label. (per: https://operator-framework.github.io/olm-book/docs/multiarch.html)

Version-Release number of selected component (if applicable):

Currently 3 operators are supported:
cluster-logging-operator
cluster-nfd-operator
elasticsearch-operator

This impacts master all the way to 4.3.

How reproducible:
Consistently.

Steps to Reproduce:
1. On an s390x or ppc64le OCP 4.4+ deploy go to the OperatorHub

Actual results:
No operators are shown.


Expected results:
3 Operators that support ppc64le & s390x are shown.

Comment 5 Andy McCrae 2020-07-10 15:21:28 UTC
I've verified this on a fresh install, the Operators don't show by default, but adding an additional operatorsource with the operators built with the labels (as per the fixes) means they show up in the OperatorHub console.

Comment 6 diederich 2020-07-21 13:36:12 UTC
I have the same issue.
It seems you are saying that the operators need to adopt and add labels.

I can not believe that there is not a single operator on operatorhub that has the correct labels in place !?
That suggests a fix to the GUI panel is still required ?

Comment 7 diederich 2020-07-21 16:52:19 UTC
[root@loznew-inf ~]# kubectl describe packagemanifests | grep -F "operatorframework.io/arch." | sort | uniq -c
    345               operatorframework.io/arch.amd64=supported
for sure people will think that the manifest for the image is good enough of a listing of arch support ? Now it needs to be duplicated into additional labels ?

Comment 11 errata-xmlrpc 2020-10-27 16:08:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.