Bug 1850583 - [v2v][UI]VM import RHV to CNV: wrong error message when wrong ca certificates are provided
Summary: [v2v][UI]VM import RHV to CNV: wrong error message when wrong ca certificates...
Keywords:
Status: VERIFIED
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Filip Krepinsky
QA Contact: Maayan Hadasi
URL:
Whiteboard: ux_issue
: 1850231 (view as bug list)
Depends On: 1850231
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-24 13:53 UTC by Yaacov Zamir
Modified: 2020-09-22 12:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1850231
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 6496 None closed Bug 1850583: add better connection error message for VM Import 2020-09-22 06:39:41 UTC

Description Yaacov Zamir 2020-06-24 13:53:29 UTC
+++ This bug was initially created as a clone of Bug #1850231 +++

Description of problem:
In UI, VM import wizard, when picking RHV provider, and providing correct connection details, except for ca certificate (deleted a raw from  

Version-Release number of selected component (if applicable):
CNV-2.4
vm-import-operator: quay.io/kubevirt/vm-import-operator:v0.0.3
vm-import-controller: quay.io/kubevirt/vm-import-controller:v0.0.3

This message is displayed:
"Can not verify RHV API credentials, connection to the OvirtProvider failed."

Though RHV credentials (user/password) are correct.
The ca certificate is wrong.

--- Additional comment from Piotr Kliczewski on 2020-06-24 07:09:04 UTC ---

In this specific case we got handshake error. We should display a generic message that provided connection information is not correct.

Comment 1 Yaacov Zamir 2020-06-24 14:17:00 UTC
*** Bug 1850231 has been marked as a duplicate of this bug. ***

Comment 2 Tomas Jelinek 2020-07-10 06:53:19 UTC
There has been a big batch of v2v related bugs moved to kubevirt plugin at once. We are working on them but due to capacity this did not make it last sprint.

Comment 4 Filip Krepinsky 2020-08-10 16:33:13 UTC
Let's just reword the message as Piotr mentioned

Comment 7 Maayan Hadasi 2020-09-22 12:40:10 UTC
Verified as fixed.
Tested with OCP 4.6/CNV 2.5

When providing wrong CA certificate and all other RHV provider details are correct, the connection fails with this error:
"Provided connection information is not correct. Connection to the RHV API failed."


Note You need to log in before you can comment on or make changes to this bug.