This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 185077 - screensaver locks user out in Xnest session
screensaver locks user out in Xnest session
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-10 07:10 EST by Scott Tsai
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-29 10:56:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gnome-screensaver-running-under-gdm.patch (445 bytes, patch)
2006-05-29 10:47 EDT, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Scott Tsai 2006-03-10 07:10:56 EST
Description of problem:
When editing a profile, leave the Xnest session idle for a few minutes and the
screensaver will run inside Xnest and ask for the password of 'sabayon-admin',
which the user does not know.

Version-Release number of selected component (if applicable):
sabayon-2.12.3-2

How reproducible:
always

Steps to Reproduce:
1. open sabayon
2. edit a profile
3. leave idle Xnest session for a while
  
Actual results:
screensaver asks for sabayon-admin password.

Expected results:
no screensaver

Additional info:
Suggest disabling screensaver for sabayon profile editing sessions.
Comment 1 Mark McLoughlin 2006-03-10 07:39:53 EST
Hmm, we added this to prevent it:

      # Disable Xscreensaver locking
      new_environ["RUNNING_UNDER_GDM"] = "yes"

Maybe gnome-screensaver doesn't support that?
Comment 2 Scott Tsai 2006-03-10 09:22:26 EST
Inside the Xnest session:
  $ echo $RUNNING_UNDER_GDM
  yes

package:
gnome-screensaver-2.13.92-2

So apparently gnome-screensaver does not support it.
By the way, do you really like the name 'RUNNING_UNDER_GDM'?
Comment 3 Mark McLoughlin 2006-05-29 10:47:35 EDT
Created attachment 130193 [details]
gnome-screensaver-running-under-gdm.patch

Problem is that gnome-screensaver isn't passing the RUNNING_UNDER_GDM env
variable to gnome-screenaver dialog. Attaching a fix

Turns out this is already fixed upstream
Comment 4 Mark McLoughlin 2006-05-29 10:51:39 EDT
Ray: might be nice to do an FC5 update but it's not a huge deal, so feel free to
close as fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.