Bug 185079 - Should we install numpy headers in /usr/include instead?
Should we install numpy headers in /usr/include instead?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: numpy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On:
Blocks: 185397
  Show dependency treegraph
 
Reported: 2006-03-10 07:47 EST by Neal Becker
Modified: 2010-03-02 14:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-02 13:27:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2006-03-10 07:47:36 EST
Description of problem:  
  
Headers in site-packages/ /numpy/core/include/numpy should probably be 
installed to /usr/include/python-version/numpy/ 
 
Version-Release number of selected component (if applicable):  
  
  
How reproducible:  
  
  
Steps to Reproduce:  
1.  
2.  
3.  
    
Actual results:  
  
  
Expected results:  
  
  
Additional info:
Comment 1 Ignacio Vazquez-Abrams 2006-03-17 08:45:38 EST
How much would code using these headers have to change in order to work with this?
Comment 2 Neal Becker 2006-04-16 08:22:03 EDT
I don't know.  What code is using these headers and expecting to find it in 
the original location? 
 
I forgot the original motivation for this request, but I suspect it was 
because I couldn't build scipy without this change. 
Comment 3 Jarod Wilson 2006-09-05 16:42:43 EDT
For the moment, I'm going to close this wontfix, since neither the impacts or
benefits are known at the moment. I have no problem moving them with proper
justification though, so feel free to reopen if there's a compelling reason to
do so.
Comment 4 Thomas Spura 2010-02-19 08:34:12 EST
(In reply to comment #3)
> For the moment, I'm going to close this wontfix, since neither the impacts or
> benefits are known at the moment. I have no problem moving them with proper
> justification though, so feel free to reopen if there's a compelling reason to
> do so.    

Reopening.

When using cython and 'cimport numpy as np' cython wants to have that headers in /usr/include/ and therefore it would be great to have them there. For now I just copied the header files manually :(


(In reply to comment #1)
> How much would code using these headers have to change in order to work with
> this?    

Cython uses a setup.py file, see [1] to this would need to be changed upstream completely. Because upstream didn't do that before, I assume, they use a distro, in which the headers are in /usr/include/

Ubuntu symlinks from /usr/include/numpy -> /usr/share/pyshared/numpy/core/include/numpy
[2]


[1] http://docs.cython.org/src/userguide/source_files_and_compilation.html#basic-setup-py
[2] http://packages.ubuntu.com/search?searchon=contents&keywords=numpy&mode=filename&suite=karmic&arch=any
Comment 5 Jon Ciesla 2010-02-23 16:29:14 EST
Would a symlink for a directory suffice here?
Comment 6 Neal Becker 2010-02-23 20:11:24 EST
I don't see why not, although I think for Fedora this is a bit unconventional.
Comment 7 Neal Becker 2010-02-24 19:54:45 EST
Looks like the same subject was discussed here:

http://permalink.gmane.org/gmane.comp.python.numeric.general/36425
Comment 8 Jon Ciesla 2010-03-02 13:27:04 EST
Fixed and built in rawhide.
Comment 9 Neal Becker 2010-03-02 13:45:30 EST
What is the decision then?  Install headers?  Install symlinks?  Do neither?
Comment 10 Jon Ciesla 2010-03-02 14:03:07 EST
1 symlink.

Note You need to log in before you can comment on or make changes to this bug.