This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 185081 - soft lockup detected on CPU#0!
soft lockup detected on CPU#0!
Status: CLOSED DUPLICATE of bug 181856
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: James Morris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-10 09:01 EST by Murali D
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-10 10:44:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Murali D 2006-03-10 09:01:32 EST
Description of problem:

I have created a guest OS on a xeon 32 bit dual server with hyperthreading 4 CPUS..
[root@jack1 usr]# xm list
Name                              ID Mem(MiB) VCPUs State  Time(s)
Domain-0                           0     1111     4 r-----  1468.1
vm11                               2      900     4 r-----   150.0

I shared home directory of Domain-0 on vm11 and tried to execute a parallel
program.... It was occupying healthy resources... but mmade the guest OS hang..
The following was the bug found from guest OS...



BUG: soft lockup detected on CPU#0!

Pid: 1153, comm:                 runK
EIP: 0073:[<00acda10>] CPU: 0
EIP is at 0xacda10
 ESP: 007b:bf9d2210 EFLAGS: 00000212    Not tainted  (2.6.15-1.1955_FC5guest)
EAX: 470ad128 EBX: 00ae6ff4 ECX: be93a195 EDX: 08a99004
ESI: 0000425d EDI: 0a32a104 EBP: bf9d2258 DS: 007b ES: 007b
CR0: 80050033 CR2: b7f12000 CR3: 2d4fd000 CR4: 00000600
BUG: soft lockup detected on CPU#0!

Pid: 1047, comm:             rpciod/0
EIP: 0061:[<c02387c6>] CPU: 0
EIP is at __tcp_select_window+0x68/0xf9
 EFLAGS: 00000206    Not tainted  (2.6.15-1.1955_FC5guest)
EAX: 0000ffff EBX: 0001fffe ECX: 00000002 EDX: 00000000
ESI: 000005a8 EDI: edbf255c EBP: 0001fffe DS: 007b ES: 007b
CR0: 8005003b CR2: b7f12000 CR3: 2d4fd000 CR4: 00000600
 [<c02300e6>] cleanup_rbuf+0xbd/0xd4
 [<c0231700>] tcp_read_sock+0x156/0x162
 [<f4862d68>] xs_tcp_data_ready+0x59/0x69 [sunrpc]
 [<f486236a>] xs_tcp_data_recv+0x0/0x491 [sunrpc]
 [<c023810c>] tcp_rcv_established+0x403/0x68b
 [<c023cc5a>] tcp_v4_do_rcv+0x23/0x2ea
 [<c023f19d>] tcp_v4_rcv+0x8c9/0x940
 [<c0264153>] _spin_unlock+0x6/0x8
 [<c013a3d3>] __do_IRQ+0xcf/0xdc
 [<c0227790>] ip_local_deliver+0x134/0x1fc
 [<c02275de>] ip_rcv+0x411/0x48f
 [<c020e995>] netif_receive_skb+0x22b/0x279
 [<f482fc4e>] netif_poll+0x554/0x741 [xennet]
 [<c0210205>] net_rx_action+0xcd/0x201
 [<c011e382>] __do_softirq+0x70/0xef
 [<c011e441>] do_softirq+0x40/0x67
 [<c011e532>] local_bh_enable+0x6c/0x78
 [<f4864512>] rpc_wake_up_next+0x116/0x11d [sunrpc]
 [<f48613af>] xprt_release+0x138/0x14b [sunrpc]
 [<f4863f38>] rpc_release_task+0xb4/0x122 [sunrpc]
 [<f486412d>] __rpc_execute+0x187/0x192 [sunrpc]
 [<c0127de2>] run_workqueue+0x80/0xbc
 [<f4864138>] rpc_async_schedule+0x0/0x9 [sunrpc]
 [<c0128601>] worker_thread+0x0/0x121
 [<c01286f1>] worker_thread+0xf0/0x121
 [<c0113c46>] default_wake_function+0x0/0x15
 [<c012b09e>] kthread+0xa0/0xcd
 [<c012affe>] kthread+0x0/0xcd
 [<c01059a5>] kernel_thread_helper+0x5/0xb




Version-Release number of selected component (if applicable):
Kernel version : 2.6.15-1.1955_FC5hypervisor

How reproducible: Running the program again may hang it again...



Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info: Normal Fortran programs went thro' successfully....
Comment 1 Murali D 2006-03-10 09:09:19 EST
Same for all instance of virtual CPUS...

BUG: soft lockup detected on CPU#0!

Pid: 1153, comm:                 runK
EIP: 0073:[<08072cb0>] CPU: 0
EIP is at 0x8072cb0
 ESP: 007b:bf9d2190 EFLAGS: 00000202    Not tainted  (2.6.15-1.1955_FC5guest)
EAX: 0a1ef9c4 EBX: 000210f0 ECX: 000210c0 EDX: 000210c1
ESI: 000218a0 EDI: 0a0b5284 EBP: bf9d2268 DS: 007b ES: 007b
CR0: 80050033 CR2: 40095000 CR3: 2d4fd000 CR4: 00000600
BUG: soft lockup detected on CPU#0!

Pid: 1047, comm:             rpciod/0
EIP: 0061:[<c01e5206>] CPU: 0
EIP is at _raw_spin_unlock+0x6d/0x70
 EFLAGS: 00000246    Not tainted  (2.6.15-1.1955_FC5guest)
EAX: 00000000 EBX: c0554000 ECX: c5317000 EDX: c1989958
ESI: f1fea8e8 EDI: 000005a8 EBP: 000071a8 DS: 007b ES: 007b
CR0: 8005003b CR2: 40095000 CR3: 2d4fd000 CR4: 00000600
 [<c0264153>] _spin_unlock+0x6/0x8
 [<f4862784>] xs_tcp_data_recv+0x41a/0x491 [sunrpc]
 [<c02315fd>] tcp_read_sock+0x53/0x162
 [<f4862d68>] xs_tcp_data_ready+0x59/0x69 [sunrpc]
 [<f486236a>] xs_tcp_data_recv+0x0/0x491 [sunrpc]
 [<c023810c>] tcp_rcv_established+0x403/0x68b
 [<c023cc5a>] tcp_v4_do_rcv+0x23/0x2ea
 [<c023f19d>] tcp_v4_rcv+0x8c9/0x940
 [<c0264153>] _spin_unlock+0x6/0x8
 [<c013a3d3>] __do_IRQ+0xcf/0xdc
 [<c0227790>] ip_local_deliver+0x134/0x1fc
 [<c02275de>] ip_rcv+0x411/0x48f
 [<c020e995>] netif_receive_skb+0x22b/0x279
 [<f482fc4e>] netif_poll+0x554/0x741 [xennet]
 [<c0210205>] net_rx_action+0xcd/0x201
 [<c011e382>] __do_softirq+0x70/0xef
 [<c011e441>] do_softirq+0x40/0x67
 [<c011e532>] local_bh_enable+0x6c/0x78
 [<f4864512>] rpc_wake_up_next+0x116/0x11d [sunrpc]
 [<f48613af>] xprt_release+0x138/0x14b [sunrpc]
 [<f4863f38>] rpc_release_task+0xb4/0x122 [sunrpc]
 [<f486412d>] __rpc_execute+0x187/0x192 [sunrpc]
 [<c0127de2>] run_workqueue+0x80/0xbc
 [<f4864138>] rpc_async_schedule+0x0/0x9 [sunrpc]
 [<c0128601>] worker_thread+0x0/0x121
 [<c01286f1>] worker_thread+0xf0/0x121
 [<c0113c46>] default_wake_function+0x0/0x15
 [<c012b09e>] kthread+0xa0/0xcd
 [<c012affe>] kthread+0x0/0xcd
 [<c01059a5>] kernel_thread_helper+0x5/0xb
BUG: soft lockup detected on CPU#0!

Pid: 51, comm:              pdflush
EIP: 0061:[<c0104227>] CPU: 0
EIP is at 0xc0104227
 EFLAGS: 00000246    Not tainted  (2.6.15-1.1955_FC5guest)
EAX: 00030000 EBX: 00000000 ECX: 00000000 EDX: fbbdc000
ESI: 00000000 EDI: 00000400 EBP: f2648000 DS: 007b ES: 007b
CR0: 8005003b CR2: 40095000 CR3: 2d4fd000 CR4: 00000600
 [<c01f577c>] force_evtchn_callback+0xa/0xc
 [<c020b128>] kfree_skbmem+0xb/0x69
 [<c020e9c5>] netif_receive_skb+0x25b/0x279
 [<f482fc4e>] netif_poll+0x554/0x741 [xennet]
 [<c0210205>] net_rx_action+0xcd/0x201
 [<c011e382>] __do_softirq+0x70/0xef
 [<c011e441>] do_softirq+0x40/0x67
 [<c011e532>] local_bh_enable+0x6c/0x78
 [<f4861155>] xprt_transmit+0xa3/0x1c5 [sunrpc]
 [<f4a9002c>] nfs3_xdr_writeargs+0x0/0x79 [nfs]
 [<f4860259>] call_transmit+0x19a/0x1d4 [sunrpc]
 [<f486401f>] __rpc_execute+0x79/0x192 [sunrpc]
 [<f4a8b87f>] nfs_execute_write+0x33/0x46 [nfs]
 [<f4a8be8d>] nfs_flush_inode+0x41f/0x4d8 [nfs]
 [<f4a8ca74>] nfs_writepages+0x63/0xcb [nfs]
 [<c014081a>] do_writepages+0x23/0x39
 [<c0175844>] __writeback_single_inode+0x196/0x32b
 [<c015da2c>] sync_supers+0x6c/0xe9
 [<c012ea6e>] debug_mutex_add_waiter+0x8c/0x9c
 [<c015da2c>] sync_supers+0x6c/0xe9
 [<c02638d7>] __mutex_lock_slowpath+0x2dc/0x416
 [<c0175ea3>] sync_sb_inodes+0x190/0x250
 [<c01410b1>] pdflush+0x0/0x198
 [<c0176173>] writeback_inodes+0x8f/0xdf
 [<c014096a>] wb_kupdate+0xb3/0x115
 [<c01411b2>] pdflush+0x101/0x198
 [<c01408b7>] wb_kupdate+0x0/0x115
 [<c012b09e>] kthread+0xa0/0xcd
 [<c012affe>] kthread+0x0/0xcd
 [<c01059a5>] kernel_thread_helper+0x5/0xb
BUG: soft lockup detected on CPU#2!

Pid: 1154, comm:                 runK
EIP: 0073:[<08072a55>] CPU: 2
EIP is at 0x8072a55
 ESP: 007b:bfcb4b20 EFLAGS: 00000246    Not tainted  (2.6.15-1.1955_FC5guest)
EAX: 497321a9 EBX: 00022795 ECX: 00022775 EDX: 00022776
ESI: 00022e55 EDI: 0fe0f984 EBP: bfcb4bf8 DS: 007b ES: 007b
CR0: 80050033 CR2: b7f12000 CR3: 3272e000 CR4: 00000600
BUG: soft lockup detected on CPU#0!

Pid: 4, comm:           watchdog/0
EIP: 0061:[<c01c2231>] CPU: 0
EIP is at selinux_socket_sock_rcv_skb+0xff/0x20b
 EFLAGS: 00210246    Not tainted  (2.6.15-1.1955_FC5guest)
EAX: 00000000 EBX: f2648000 ECX: 00000004 EDX: edbf265c
ESI: c06fbd9c EDI: c06fbdc4 EBP: 00010002 DS: 007b ES: 007b
CR0: 8005003b CR2: 00386fb0 CR3: 019be000 CR4: 00000600
 [<c023ec8f>] tcp_v4_rcv+0x3bb/0x940
 [<c0264153>] _spin_unlock+0x6/0x8
 [<c013a3d3>] __do_IRQ+0xcf/0xdc
 [<c0227790>] ip_local_deliver+0x134/0x1fc
 [<c02275de>] ip_rcv+0x411/0x48f
 [<c020e995>] netif_receive_skb+0x22b/0x279
 [<f482fc4e>] netif_poll+0x554/0x741 [xennet]
 [<c0210205>] net_rx_action+0xcd/0x201
 [<c011e382>] __do_softirq+0x70/0xef
 [<c011e441>] do_softirq+0x40/0x67
 [<c010927b>] do_IRQ+0x22/0x28
 [<c01f5c52>] evtchn_do_upcall+0x63/0x9d
 [<c013a20e>] watchdog+0x0/0x62
 [<c0107c4c>] hypervisor_callback+0x2c/0x34
 [<c013a20e>] watchdog+0x0/0x62
 [<c012007b>] proc_doutsstring+0x7/0xb0
 [<c0121a0b>] msleep_interruptible+0x1f/0x41
 [<c013a24d>] watchdog+0x3f/0x62
 [<c012b09e>] kthread+0xa0/0xcd
 [<c012affe>] kthread+0x0/0xcd
 [<c01059a5>] kernel_thread_helper+0x5/0xb
BUG: soft lockup detected on CPU#3!

Pid: 1157, comm:                 runK
EIP: 0073:[<08073093>] CPU: 3
EIP is at 0x8073093
 ESP: 007b:bfa9cdc0 EFLAGS: 00000206    Not tainted  (2.6.15-1.1955_FC5guest)
EAX: 0a1ef9c4 EBX: 0001f8fd ECX: 0001f8e9 EDX: 0001f8ea
ESI: 0001fa51 EDI: 0a0b5284 EBP: bfa9ce98 DS: 007b ES: 007b
CR0: 80050033 CR2: bfd367e6 CR3: 2d2d8000 CR4: 00000600

Comment 2 James Morris 2006-03-10 10:44:27 EST

*** This bug has been marked as a duplicate of 181856 ***

Note You need to log in before you can comment on or make changes to this bug.