Bug 1850812 - Ingress Operator Fails to Delete DNSRecord
Summary: Ingress Operator Fails to Delete DNSRecord
Keywords:
Status: CLOSED DUPLICATE of bug 1850813
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Andrew McDermott
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-24 23:13 UTC by Daneyon Hansen
Modified: 2020-06-25 16:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-25 16:15:08 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Daneyon Hansen 2020-06-24 23:13:51 UTC
Description of problem:
The Ingress Operator fails to delete the wildcard dns record when the recors is not cached.

Version-Release number of selected component (if applicable):
$ oc get clusterversions.config.openshift.io
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.6.0-0.nightly-2020-06-23-160540   True        False         6h23m   Cluster version is 4.6.0-0.nightly-2020-06-23-160540


How reproducible:
Always

Steps to Reproduce:
1. Install an AWS cluster using IPI
2. Kill ingress operator to remove the cached dnsrecord
3. Start the ingress operator
4. Delete the default ingresscontroller

Actual results:
2020-06-24T16:10:31.413-0700	ERROR	operator.dns_controller	dns/controller.go:88	failed to delete dnsrecord; will retry	{"dnsrecord": {"metadata":{"name":"default-wildcard","namespace":"openshift-ingress-operator","selfLink":"/apis/ingress.operator.openshift.io/v1/namespaces/openshift-ingress-operator/dnsrecords/default-wildcard","uid":"fcd8789a-dad4-411d-a6c1-689ca55efa4c","resourceVersion":"271966","generation":2,"creationTimestamp":"2020-06-24T23:09:12Z","deletionTimestamp":"2020-06-24T23:10:30Z","deletionGracePeriodSeconds":0,"labels":{"ingresscontroller.operator.openshift.io/owning-ingresscontroller":"default"},"ownerReferences":[{"apiVersion":"operator.openshift.io/v1","kind":"IngressController","name":"default","uid":"fb11358d-a3dd-4015-83bf-a3168fbc3e34","controller":true,"blockOwnerDeletion":true}],"finalizers":["operator.openshift.io/ingress-dns"],"managedFields":[{"manager":"ingress-operator","operation":"Update","apiVersion":"ingress.operator.openshift.io/v1","time":"2020-06-24T23:09:14Z","fieldsType":"FieldsV1","fieldsV1":{"f:metadata":{"f:finalizers":{".":{},"v:\"operator.openshift.io/ingress-dns\"":{}},"f:labels":{".":{},"f:ingresscontroller.operator.openshift.io/owning-ingresscontroller":{}},"f:ownerReferences":{".":{},"k:{\"uid\":\"fb11358d-a3dd-4015-83bf-a3168fbc3e34\"}":{".":{},"f:apiVersion":{},"f:blockOwnerDeletion":{},"f:controller":{},"f:kind":{},"f:name":{},"f:uid":{}}}},"f:spec":{".":{},"f:dnsName":{},"f:recordTTL":{},"f:recordType":{},"f:targets":{}},"f:status":{".":{},"f:observedGeneration":{},"f:zones":{}}}}]},"spec":{"dnsName":"*.apps.dhansen.devcluster.openshift.com.","targets":["a3c35848dd37540b4bb0b54d1e3f84bf-105426093.us-west-2.elb.amazonaws.com"],"recordType":"CNAME","recordTTL":30},"status":{"zones":[{"dnsZone":{"tags":{"Name":"dhansen-ksg8r-int","kubernetes.io/cluster/dhansen-ksg8r":"owned"}},"conditions":[{"type":"Failed","status":"False","lastTransitionTime":"2020-06-24T23:09:12Z","reason":"ProviderSuccess","message":"The DNS provider succeeded in ensuring the record"}]},{"dnsZone":{"id":"Z3URY6TWQ91KVV"},"conditions":[{"type":"Failed","status":"False","lastTransitionTime":"2020-06-24T23:09:14Z","reason":"ProviderSuccess","message":"The DNS provider succeeded in ensuring the record"}]}],"observedGeneration":1}}, "error": "failed to get hosted zone for load balancer target \"a3c35848dd37540b4bb0b54d1e3f84bf-105426093.us-west-2.elb.amazonaws.com\": couldn't find hosted zone ID of ELB a3c35848dd37540b4bb0b54d1e3f84bf-105426093.us-west-2.elb.amazonaws.com", "errorCauses": [{"error": "failed to get hosted zone for load balancer target \"a3c35848dd37540b4bb0b54d1e3f84bf-105426093.us-west-2.elb.amazonaws.com\": couldn't find hosted zone ID of ELB a3c35848dd37540b4bb0b54d1e3f84bf-105426093.us-west-2.elb.amazonaws.com"}, {"error": "failed to get hosted zone for load balancer target \"a3c35848dd37540b4bb0b54d1e3f84bf-105426093.us-west-2.elb.amazonaws.com\": couldn't find hosted zone ID of ELB a3c35848dd37540b4bb0b54d1e3f84bf-105426093.us-west-2.elb.amazonaws.com"}]}

Expected results:
The default ingresscontroller and dependent resources are deleted.

Additional info:

Comment 1 Andrew McDermott 2020-06-25 16:15:08 UTC

*** This bug has been marked as a duplicate of bug 1850813 ***


Note You need to log in before you can comment on or make changes to this bug.