Bug 185102 - rhgb randomly switches to tty1
rhgb randomly switches to tty1
Status: CLOSED DUPLICATE of bug 166150
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhgb (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-10 12:18 EST by Daniel W. Ottey
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-10 15:19:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel W. Ottey 2006-03-10 12:18:46 EST
We are still seeing this in RHEL4 Update 3!
+++ This bug was initially created as a clone of Bug #147910 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
If kudzu detects new or removed hardware, it prompts you to press a
key.  If you press a key, but don't answer all its questions within a
fairly short period of time, it times out, kudzu disappears.  Boot
does not continue, but you are stuck on a text screen, with the last
message being about enabling swap.

Reboot is required at that point.

(The timeout is roughly 30 sec. or less, maybe per question.)

Version-Release number of selected component (if applicable):
kudzu-1.1.95-1

How reproducible:
Always

Steps to Reproduce:
1. Add or remove hardware that kudzu will notice.
2. Boot/reboot, and press a key when the initial kudzu prompt comes up.
3. When kudzu asks what do do with the hardware, don't do anything.

Actual Results:  After a short period of time (maybe 30 seconds, give
or take), the kudzu screen disappears, replaced by a black and white
text screen.  The last message on the screen is about enabling swap. 
Nothing more happens.  Boot does not continue, and a reboot is required.

Expected Results:  The system should wait until all the kudzu
questions have been answered.  Or, at least, the system should
continue to boot after the timeout.

Additional info:

-- Additional comment from notting@redhat.com on 2005-02-14 13:45 EST --
Are you using rhgb?


-- Additional comment from bill-redhat@uncultured.org on 2005-02-14 16:31 EST --
Yes, I'm using rhgb.

-- Additional comment from notting@redhat.com on 2005-02-14 16:36 EST --
Does it recur if you *don't* use rhgb?

-- Additional comment from notting@redhat.com on 2005-03-14 12:54 EST --
This is a rhgb bug; it's randomly switching to tty1.

(If you're in this situation, ctrl-alt-f7 or f8 should get you back to
rhgb.)
Comment 1 Ray Strode [halfline] 2006-03-10 15:19:09 EST
Hi,

This particular bug has already been reported into our bug tracking system.  A
fix is currently being evaluated for potential inclusion in a future Red Hat
Enterprise Linux 4 update.  If you have further questions, feel free to file a
problem report with Red Hat Global Support Services at
https://www.redhat.com/apps/support/ and mention bug 166150.

*** This bug has been marked as a duplicate of 166150 ***

Note You need to log in before you can comment on or make changes to this bug.