This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 185103 - Python distutils reports incorrect lib location (2)
Python distutils reports incorrect lib location (2)
Status: CLOSED DUPLICATE of bug 185352
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: python (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-10 12:32 EST by Tru Huynh
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-20 18:21:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tru Huynh 2006-03-10 12:32:39 EST
Description of problem:


Version-Release number of selected component (if applicable):
python-2.2.3-6.2.x86_64

How reproducible:

Always

Steps to Reproduce:
1. python -c 'from distutils import sysconfig; print sysconfig.get_python_lib(),
sysconfig.get_python_lib(1)'
2.
3.
  
Actual results:
/usr/lib64/python2.2/site-packages /usr/lib64/python2.2/site-packages

Expected results:
/usr/lib/python2.2/site-packages /usr/lib64/python2.2/site-packages

Additional info:
python (2.3) on RHEL4 works fine:
[tru@myganne ~]$ python -c 'from distutils import sysconfig; print
sysconfig.get_python_lib(), sysconfig.get_python_lib(1)'
/usr/lib/python2.3/site-packages /usr/lib64/python2.3/site-packages
[tru@myganne ~]$ rpm -q python
python-2.3.4-14.1.x86_64
Comment 1 Tru Huynh 2006-03-10 12:34:12 EST
in the same league as https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=144094

also reported (with possible fix) at http://bugs.centos.org/view.php?id=1244
Comment 4 Jeremy Katz 2006-12-20 18:21:41 EST

*** This bug has been marked as a duplicate of 185352 ***

Note You need to log in before you can comment on or make changes to this bug.