Bug 1851088 - console hit runtime error when all receivers are deleted
Summary: console hit runtime error when all receivers are deleted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.z
Assignee: David Taylor
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1849739 (view as bug list)
Depends On: 1849556
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-25 15:15 UTC by OpenShift BugZilla Robot
Modified: 2020-08-10 13:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: 1. goto monitoring/alertmanageryaml page, and delete all receivers including Critical, Default and Watchdog 2. refresh the page Consequence: get a blank page and runtime error: Uncaught TypeError: Cannot read property 'filter' of undefined Fix: null and empty logic tests were added Result: correctly displays the empty state screen when all receivers deleted.
Clone Of:
Environment:
Last Closed: 2020-08-10 13:50:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
Verification screenshot (35.19 KB, image/png)
2020-07-31 03:03 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5826 None closed [release-4.5.z] Bug 1851088: console hit runtime error when all receivers are deleted 2020-08-06 20:54:14 UTC
Red Hat Product Errata RHBA-2020:3188 None None None 2020-08-10 13:50:44 UTC

Comment 1 David Taylor 2020-06-25 15:43:29 UTC
*** Bug 1849739 has been marked as a duplicate of this bug. ***

Comment 2 Joe Caiani 2020-07-10 15:48:16 UTC
will investigate next sprint

Comment 5 XiaochuanWang 2020-07-31 03:03:55 UTC
Created attachment 1703027 [details]
Verification screenshot

Comment 6 XiaochuanWang 2020-07-31 03:05:17 UTC
Tried for several times, this is not reproduced (attached the screenshot for refer)
Verified on 4.5.0-0.nightly-2020-07-30-213620

Comment 8 errata-xmlrpc 2020-08-10 13:50:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.5 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3188


Note You need to log in before you can comment on or make changes to this bug.