Bug 1851157 - Slow manifest import and/or refresh
Summary: Slow manifest import and/or refresh
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Subscription Management
Version: 6.7.0
Hardware: Unspecified
OS: Unspecified
high
unspecified vote
Target Milestone: 6.7.2
Assignee: Jonathon Turel
QA Contact: Cole Higgins
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-25 16:50 UTC by Mike McCune
Modified: 2020-07-30 23:16 UTC (History)
4 users (show)

Fixed In Version: tfm-rubygem-katello-3.14.0.21-1,tfm-rubygem-katello-3.14.0.23-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1847063
Environment:
Last Closed: 2020-07-30 20:21:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 30101 0 Normal Closed Cleanup data more efficiently when importing backend objects 2020-08-28 15:52:02 UTC
Red Hat Knowledge Base (Solution) 5219231 0 None None None 2020-07-30 23:16:13 UTC
Red Hat Product Errata RHBA-2020:3255 0 None None None 2020-07-30 20:21:25 UTC

Description Mike McCune 2020-06-25 16:50:18 UTC
+++ This bug was initially created as a clone of Bug #1847063 +++

Description of problem:

In cases where there are a lot of content hosts attached to a single subscription and that subscription expires, manifest import and refresh can be *very* slow as the import cleans up data relating to the expired subscription.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from  on 2020-06-15T14:48:35Z 

Connecting redmine issue https://projects.theforeman.org/issues/30101 from this bug

Comment 9 errata-xmlrpc 2020-07-30 20:21:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3255


Note You need to log in before you can comment on or make changes to this bug.