Bug 1851166 - Make btrfs the default file system for desktop variants
Summary: Make btrfs the default file system for desktop variants
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Chris Murphy
QA Contact:
URL:
Whiteboard:
: 689509 (view as bug list)
Depends On: 1855522 1860602 1885102 1851270 1851287 1855000 1855174 1858535 1860720 1861108 1876261
Blocks: F33Changes
TreeView+ depends on / blocked
 
Reported: 2020-06-25 16:54 UTC by Ben Cotton
Modified: 2020-10-27 14:47 UTC (History)
23 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 14:47:40 UTC
Type: Bug


Attachments (Terms of Use)

Description Ben Cotton 2020-06-25 16:54:26 UTC
This is the tracker bug for the Fedora change proposal: https://fedoraproject.org/wiki/Changes/BtrfsByDefault

Summary:
For laptop and workstation installs of Fedora, we want to provide file system features to users in a transparent fashion. We want to add new features, while reducing the amount of expertise needed to deal with situations like running out of disk space. Btrfs is well adapted to this role by design philosophy, let's make it the default.

Comment 1 Michel Alexandre Salim 2020-06-25 17:18:25 UTC
One thing to note: currently `autopart --type=btrfs` leads to a btrfs volume with /boot on xfs, not ext4.

I'll be playing with these on top of Fedora 32 in my repo -- currently it has swap-on-zram as well (the current btrfs change doesn't mention swap much?) as well as enabling Nvidia if the GPU is detected. Not setting up subvolumes correctly though so I'll fix that.

  https://github.com/michel-slm/luks-kickstarts/blob/master/luks-btrfs-zram-nvidia-ws.ks

Comment 2 Neal Gompa 2020-06-25 17:22:16 UTC
(In reply to Michel Alexandre Salim from comment #1)
> One thing to note: currently `autopart --type=btrfs` leads to a btrfs volume
> with /boot on xfs, not ext4.
> 

That should be fixed, for sure...

> I'll be playing with these on top of Fedora 32 in my repo -- currently it
> has swap-on-zram as well (the current btrfs change doesn't mention swap
> much?) as well as enabling Nvidia if the GPU is detected. Not setting up
> subvolumes correctly though so I'll fix that.
> 

We leave swap setup as it would do normally. Swap on ZRAM separately changes how we deal with swap.

Comment 3 Neal Gompa 2020-06-28 21:09:43 UTC
*** Bug 689509 has been marked as a duplicate of this bug. ***

Comment 4 Ben Cotton 2020-08-11 14:42:22 UTC
Branching F33 Change Tracker bugs.

Today is the code complete (testable) deadline. All bugs should be at least in MODIFIED state by now to indicate they are testable.

Comment 5 Ben Cotton 2020-10-27 14:47:40 UTC
Closing tracking bugs for F33. If your change didn't make it into F33 for some reason, please reopen this and NEEDINFO me.


Note You need to log in before you can comment on or make changes to this bug.