Bug 185122 - gpgme-config --libs omits -lgpg-error
gpgme-config --libs omits -lgpg-error
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gpgme (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-10 14:53 EST by Allen Winter
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-12 18:31:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allen Winter 2006-03-10 14:53:08 EST
Description of problem:
/usr/bin/gpgme-config --libs should print -lgpgme -lgpg-error
instead it prints -lgpgme only.

I see that the following line is commentd-out in /usr/bin/gpgme-config:
gpg_error_libs="-lgpg-error"

I think it needs to be uncommented.

This is a high severity because I am a KDE developer and I can't get
some of the KDE modules to compile because of this problem.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. simply run /usr/bin/gpgme-config --libs
2.
3.
  
Actual results:
-lgpgme

Expected results:
-lgpgme -lgpg-error

Additional info:
BTW, in bugzilla there is no component for gpgme.  please add one.
So I just put this under the gnupg component.  you'll need to move this bug
to the correct component (once it has been created)
Comment 1 Nalin Dahyabhai 2006-03-10 15:03:26 EST
Fedora Extras has a gpgme component, moving.
Comment 2 Rex Dieter 2006-03-10 15:16:38 EST
IMO, If your code uses stuff from libgpg-error, then *you* should link to it,
and not depend on 'gpgme-config --libs' output to do it for you.

Furhter, gpgme developers told me in essence that "gpgme-config is for those who
do not use libtool." And, AFAIK, KDE apps/code does (should!) use libtool.  (-:

Now, after all that, you still think there's a problem with leaving -lgpg-error
out, then please post a concrete example or code so that I can take a closer look.
Comment 3 Allen Winter 2006-03-12 17:00:37 EST
Hi Rex. 
 
Ok, go ahead and close this bug. 
I'm solving the problem in a different manner using autoconf. 
 
 
Comment 4 Rex Dieter 2006-03-12 18:31:20 EST
Glad to hear you got it working.

Note You need to log in before you can comment on or make changes to this bug.