Bug 1851246 - perl-constant-tiny: FTBFS with Perl 5.32
Summary: perl-constant-tiny: FTBFS with Perl 5.32
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-constant-tiny
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-25 21:49 UTC by Jitka Plesnikova
Modified: 2020-06-26 09:35 UTC (History)
2 users (show)

Fixed In Version: perl-constant-tiny-1.02-15.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-26 09:35:38 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
CPAN 131757 None None None 2020-06-25 21:49:59 UTC

Description Jitka Plesnikova 2020-06-25 21:49:59 UTC
Description of problem:
Package perl-constant-tiny fails to build from source in Fedora rawhide with perl 5.32.

Attempt to reload constant.pm aborted.
Compilation failed in require at t/constant.t line 16.
BEGIN failed--compilation aborted at t/constant.t line 16.
# Looks like your test exited with 255 before it could output anything.
t/constant.t .. 
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 95/95 subtests

Comment 1 Petr Pisar 2020-06-26 08:40:50 UTC
I'm keen to retire this package. It's not needed by anything in Fedora, and the purpose of this module diminished when core constant module started to delay the loading of an expensive utf8_heavy.pl module.

Comment 2 Petr Pisar 2020-06-26 08:50:09 UTC
A reproducer:

$ perl -Ilib -e 'use constant::tiny; use constant;'
Attempt to reload constant.pm aborted.
Compilation failed in require at -e line 1.
BEGIN failed--compilation aborted at -e line 1.

Comment 3 Petr Pisar 2020-06-26 09:35:38 UTC
It was a simple fix.


Note You need to log in before you can comment on or make changes to this bug.