Bug 185125 - "starting web browser" shows for a long time
"starting web browser" shows for a long time
Status: CLOSED DUPLICATE of bug 156710
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-03-10 15:15 EST by Ben Maurer
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-11 18:10:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Maurer 2006-03-10 15:15:32 EST
On the latest FC5, do the following:

1. Click the web browser button on the panel
2. Wait for ff to show up
3. Click again
4. Wait for ff to open a new window

after step 4, the "starting web browser" will still stay there until the button
times out. This should not happen, it should go away as soon as firefox launches.
Comment 1 Warren Togami 2006-03-10 16:17:39 EST
This is not necessarily the fault of firefox, but this is a general problem with
the way application startup feedback works.  We need to figure out a general
solution to use across all software.

Assigning to Matthias so he can decide what we should do.
Comment 2 Ray Strode [halfline] 2006-03-10 17:02:21 EST
No, this is probably a problem with firefox itself.  startup notification is a
known and solved problem; firefox just needs to implement it right if it's not.
Comment 3 Matthias Clasen 2006-03-11 09:31:49 EST
Ray is right. gnome-terminal is similar in that it opens a new toplevel for
each button click, and it has correct startup notification. Firefox needs
to be fixed to do the right thing.
Comment 4 Christopher Aillon 2006-03-11 18:10:00 EST
This is really bug 156710

*** This bug has been marked as a duplicate of 156710 ***

Note You need to log in before you can comment on or make changes to this bug.