This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 185137 - xend service not starting up on boot
xend service not starting up on boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
:
: 202851 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-10 16:10 EST by Bret McMillan
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 10:15:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bret McMillan 2006-03-10 16:10:50 EST
The xend does not seem to be starting up the processes I'm expecting (xenstored,
etc) on bootup, nor does /sbin/service xend [action] seem to be doing much of
anything.  Hopefully this isn't just pebkac.

[bretm@dhcp59-206 ~]$ ssh root@dhcp59-213.rdu.redhat.com
root@dhcp59-213.rdu.redhat.com's password:
Last login: Fri Mar 10 15:36:54 2006 from devserv.devel.redhat.com
[root@dhcp59-213 ~]# /sbin/chkconfig --list | grep xen
xend            0:off   1:off   2:on    3:on    4:on    5:on    6:off
xendomains      0:off   1:off   2:off   3:on    4:on    5:on    6:off
[root@dhcp59-213 ~]# /sbin/service xend status
[root@dhcp59-213 ~]# ps aux | grep xen
root        12  0.0  0.0      0     0 ?        S<   15:45   0:00 [xenwatch]
root        13  0.0  0.0      0     0 ?        S<   15:45   0:00 [xenbus]
root      2739  0.0  0.0   3928   700 pts/2    S+   15:48   0:00 grep xen
[root@dhcp59-213 ~]# uname -a
Linux dhcp59-213.rdu.redhat.com 2.6.15-1.2038_FC5xen0 #1 SMP Thu Mar 9 18:09:13
EST 2006 i686 i686 i386 GNU/Linux
[root@dhcp59-213 ~]# /sbin/service xend start
.........[root@dhcp59-213 ~]# /sbin/service xend status
[root@dhcp59-213 ~]# ps aux | grep xen
root        12  0.0  0.0      0     0 ?        S<   15:45   0:00 [xenwatch]
root        13  0.0  0.0      0     0 ?        S<   15:45   0:00 [xenbus]
root      2782  0.0  0.0   3932   704 pts/2    S+   15:51   0:00 grep xen


Manually calling '/usr/sbin/xend start' has 2 effects:

1)  results in a changed ip:
[root@dhcp59-213 ~]# /sbin/ifconfig eth0 | grep 'inet addr'
          inet addr:172.16.59.129  Bcast:172.16.59.255  Mask:255.255.252.0

  No idea if that's expected :)

2)  starts up the expected xen related processes:
[root@dhcp59-213 ~]# ps aux | grep xen
root        12  0.0  0.0      0     0 ?        S<   15:45   0:00 [xenwatch]
root        13  0.0  0.0      0     0 ?        S<   15:45   0:00 [xenbus]
root      3238  0.0  0.0   2024   672 ?        S    15:55   0:00 xenstored
--pid-file=/var/run/xenstore.pid
root      3241  0.0  0.0  12184   384 ?        Sl   15:55   0:00 xenconsoled
root      3246  0.0  0.1  10952  3668 ?        S    15:55   0:00 python
/usr/sbin/xend start
root      3247  0.0  0.2  72416  4648 ?        Sl   15:55   0:00 python
/usr/sbin/xend start
root      3320  0.0  0.0   3932   740 pts/3    S+   15:58   0:00 grep xen


If there's anything else I can provide, let me know.
Comment 1 Rik van Riel 2006-03-10 16:26:33 EST
echo 0 > /selinux/enforce fixed this problem
Comment 2 Daniel Walsh 2006-03-10 16:51:12 EST
Are you seein AVC messages in /var/log/messages of /var/log/audit/audit.log?
Comment 4 James Antill 2006-05-09 12:37:21 EDT
 Well I assume you are seeing AVC messages when you call the "service xend
start", can you post those?
Comment 5 James Antill 2006-06-06 17:35:11 EDT
 Policy has a changed a lot, and Xen too since March. Can you retest.

 Note that one thing that is known about is the _first time_ Xen is run, it
won't boot in enforcing mode atm.
Comment 6 James Antill 2006-09-20 13:16:09 EDT
*** Bug 202851 has been marked as a duplicate of this bug. ***
Comment 8 Daniel Walsh 2007-08-22 10:15:58 EDT
Should be fixed in the current release

Note You need to log in before you can comment on or make changes to this bug.