Bug 18514 - Network Configuration Script Mistake
Network Configuration Script Mistake
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-06 07:58 EDT by cradford
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 05:24:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cradford 2000-10-06 07:58:02 EDT
Script /etc/sysconfig/network-scripts/ifup-ppp only partially processes 
"DISCONNECTTIMEOUT" and "RETRYTIMEOUT" parameters. The options never get 
passed to the ppp daemon. That is, they are never added to the '$opts' 
variable as "idle ${DISCONNECTTIMEOUT}" and "holdoff ${RETRYTIMEOUT}" if 
they are not null (which they never are, as they are defaulted at the 
start of the script).
Comment 1 Thomas Woerner 2004-08-13 05:24:14 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.
Comment 2 cradford 2004-08-13 07:33:48 EDT
The ifup-ppp script distributed in rpm package "initscripts-6.43-1" 
(Red Hat 7.2), does not have this flaw. This bug can be considered 
truely stood upon (not just closed, but fixed :>)

Note You need to log in before you can comment on or make changes to this bug.