Bug 185140 - M-x man netstat in 'xemacs -f shell' gives a segmentation fault
M-x man netstat in 'xemacs -f shell' gives a segmentation fault
Status: CLOSED DUPLICATE of bug 183643
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-10 16:19 EST by Will Partain
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-13 02:14:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Will Partain 2006-03-10 16:19:06 EST
Description of problem:
XEmacs crashes whenever I do 'M-x man <return> netstat <return>'

Version-Release number of selected component (if applicable):
xemacs-21.4.19-2.fc5

How reproducible:
entirely

Steps to Reproduce:
1. start up: xemacs -f shell
2. M-x man RET netstat RET
3.
  
Actual results:
xemacs crashes

Expected results:


Additional info:
Obviously, there may be something weird in my xemacs setup that makes the
problem not reproducible.  (There is, of course, a bug in xemacs, because it
should never seg fault; but this report is only about the apparently-obvious case).
Comment 1 Jens Petersen 2006-03-12 21:01:44 EST
xemacs is now in Extras, changing product.
Comment 2 Jens Petersen 2006-03-12 21:02:49 EST
Can you reproduce with "xemacs -vanilla" or "xemacs -q"?
Comment 3 Ville Skyttä 2006-03-13 02:14:39 EST

*** This bug has been marked as a duplicate of 183643 ***
Comment 4 Will Partain 2006-03-13 04:15:24 EST
Yes, it crashes with 'xemacs -q'.  (It doesn't with 'xemacs -q -nw')
This is all with 'yum update' as of about Mar 9 but w/ kernel 2025.

(In general, this xemacs is pretty crashy, certainly compared to the current FC4
one, which almost never crashes.  I supplied this example because the recipe is
simple.)

Keep up the good work!
Comment 5 Ville Skyttä 2006-03-13 11:37:52 EST
I'm observing the same thing; xemacs is currently somewhat unstable and crashy
on FC5tX.  I'm pretty certain that this has to do with FC5's font/UTF-8
configuration issues (see bug 180284) which triggers a bug elsewhere in XEmacs
resulting in these crashes.  Note that (at least for me) starting up in a
non-UTF8 locale, eg. with "LANG=C xemacs", avoids this crash just like in bug
183643.

Note You need to log in before you can comment on or make changes to this bug.