Bug 1851668 - xdg-desktop-portal (and by extension, GNOME) depends on flatpak-selinux and ostree-libs
Summary: xdg-desktop-portal (and by extension, GNOME) depends on flatpak-selinux and o...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xdg-desktop-portal
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David King
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-28 03:49 UTC by Bryan Roessler
Modified: 2021-02-26 14:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-26 12:09:05 UTC
Type: Bug


Attachments (Terms of Use)

Description Bryan Roessler 2020-06-28 03:49:47 UTC
Description of problem:

xdg-desktop-portal has started to depend on flatpak-selinux and ostree-libs, with weak dependencies on flatpak and p11-kit-server.

I am not sure if this is intended, or not. As someone that does not use flatpak, it is strange to have my DE depend on it.


Version-Release number of selected component (if applicable):

1.7.2-2.fc32



Steps to Reproduce:
1. sudo dnf update xdg-desktop-portal

Actual results:
Last metadata expiration check: 0:09:36 ago on Sat 27 Jun 2020 11:30:34 PM EDT.
Dependencies resolved.
========================================================================================================================
 Package                            Architecture           Version                        Repository               Size
========================================================================================================================
Upgrading:
 xdg-desktop-portal                 x86_64                 1.7.2-2.fc32                   updates                 434 k
Installing dependencies:
 flatpak-selinux                    noarch                 1.6.4-1.fc32                   updates                  23 k
 ostree-libs                        x86_64                 2020.3-5.fc32                  updates                 398 k
Installing weak dependencies:
 flatpak                            x86_64                 1.6.4-1.fc32                   updates                 1.5 M
 p11-kit-server                     x86_64                 0.23.20-1.fc32                 fedora                  189 k

Transaction Summary
========================================================================================================================
Install  4 Packages
Upgrade  1 Package

Total download size: 2.5 M

Expected results:

xdg-desktop-portal updates without installing additional dependencies


Additional info:

Comment 1 Bryan Roessler 2020-09-11 16:05:28 UTC
This appears to be fixed.

Comment 2 Michael J Gruber 2021-02-23 08:11:16 UTC
This popped up again with the update from xdg-desktop-portal-1.8.0-1.fc33.x86_64 to 1.8.1-1.fc33:


Upgrading:
 xdg-desktop-portal                                 x86_64                             1.8.1-1.fc33                                 updates                             354 k
Installing dependencies:
 flatpak-selinux                                    noarch                             1.10.1-1.fc33                                updates                              23 k
 flatpak-session-helper                             x86_64                             1.10.1-1.fc33                                updates                              79 k
 ostree-libs                                        x86_64                             2020.8-1.fc33                                updates                             427 k
Installing weak dependencies:
 flatpak                                            x86_64                             1.10.1-1.fc33                                updates                             1.7 M
 p11-kit-server                                     x86_64                             0.23.22-2.fc33                               updates                             199 k
 xdg-desktop-portal-wlr                             x86_64                             0.1.0-2.fc33                                 fedora                               34 k

Transaction Summary
==============================================================================================================================================================================
Install  6 Packages
Upgrade  1 Package

Probably the same on F34.

Comment 3 Michael J Gruber 2021-02-26 11:39:11 UTC
Just in case someone needs this:

dnf update xdg-desktop-portal --setopt=install_weak_deps=False

does not pull in anything (not even the "dependencies") mentioned above. So, something is fishy about weak vs. strong.

If you do this, you might want to install xdg-desktop-portal-wlr separately if you are on wayland. (It does not pull in flatpak stuff.)

Comment 4 David King 2021-02-26 12:09:05 UTC
xdg-desktop-portal has a Recomends on flatpak, so installing flatpak on upgrade with default settings would be expected.

Comment 5 Michael J Gruber 2021-02-26 14:38:45 UTC
(In reply to David King from comment #4)
> xdg-desktop-portal has a Recomends on flatpak, so installing flatpak on
> upgrade with default settings would be expected.

This is BS on so many levels that it angers me:

- It cannot be true because otherwise xdg-portal-desktop would have pulled in flatpak before.

- It cannot be true because otherwise -setopt=install_weak_deps=False would not stop it from being pulled in.

- It simply is not true: https://src.fedoraproject.org/rpms/xdg-desktop-portal/blob/rawhide/f/xdg-desktop-portal.spec#_29

- If it were true it would be wrong to pull in flatpak as a hard dependency of gnome-shell (via xdg-desktop-portal).

Fedora is about freedom of choice.


Note You need to log in before you can comment on or make changes to this bug.