Bug 1851839 - [release 4.5] Make Insights Operator e2e tests more stable
Summary: [release 4.5] Make Insights Operator e2e tests more stable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Insights Operator
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.z
Assignee: Martin Kunc
QA Contact: Angelina Nikiforova
Radek Vokál
URL:
Whiteboard:
Depends On: 1851840
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-29 08:13 UTC by Martin Kunc
Modified: 2020-08-10 13:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1851840 (view as bug list)
Environment:
Last Closed: 2020-08-10 13:50:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift insights-operator pull 130 None closed [release-4.5] Bug 1851839: Make e2e tests more stable 2020-08-06 20:54:15 UTC
Red Hat Product Errata RHBA-2020:3188 None None None 2020-08-10 13:50:44 UTC

Description Martin Kunc 2020-06-29 08:13:13 UTC
Description of problem:
CI builds were failing on e2e tests

Version-Release number of selected component (if applicable):
4.5

How reproducible:
Because of order of running Tests in Golang is random, this can be only reproduced by running e2e tests multiple times until they fail.

Steps to Reproduce:
1. Run on Github using bot /test insights-operator-e2e-tests until it fails


Actual results:
Test fails randomly

Expected results:
Tests are passing if nothing was changed.

Additional info:

Comment 6 Angelina Nikiforova 2020-07-31 06:58:14 UTC
QA not required, tests work on GitHub

Comment 8 errata-xmlrpc 2020-08-10 13:50:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.5 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3188


Note You need to log in before you can comment on or make changes to this bug.