Bug 1851872 - Wrong tag in comment line of DKIM record: 'i=' should be 's='
Summary: Wrong tag in comment line of DKIM record: 'i=' should be 's='
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: amavis
Version: epel8
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Juan Orti
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-29 09:51 UTC by Adrian Offerman
Modified: 2020-12-03 02:09 UTC (History)
6 users (show)

Fixed In Version: amavis-2.12.1-3.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-12-03 02:09:30 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gitlab amavis/amavis/-/issues/63 0 None None None 2020-06-29 11:01:42 UTC

Description Adrian Offerman 2020-06-29 09:51:15 UTC
Description of problem:

The comment line generated with the DKIM record shows an 'i=' (identifier) tag, while this should be the 's=' (selector) tag.

Version-Release number of selected component (if applicable):

2.12.0

How reproducible:

set up a DKIM key pair in the configuration and run the command:
  amavisd -c /etc/amavisd/amavisd.conf showkeys

the first line of a/each DKIM record is a comment line, now saying something like this:
  ; key#27 4096 bits, i=dkim20191228, d=example.com, 
      /etc/amavisd/example.com.dkim20191228.pem
this should be:
  ; key#27 4096 bits, s=dkim20191228, d=example.com, 
      /etc/amavisd/example.com.dkim20191228.pem

Additional info:

Since this is only a comment line providing info on the actual record that follows, there's no harm done, other than suggesting that this is the identifier rather than the selector tag.

Comment 1 Fedora Admin user for bugzilla script actions 2020-08-05 09:16:37 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 2 Fedora Update System 2020-11-17 16:53:11 UTC
FEDORA-EPEL-2020-ca1ac5519e has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-ca1ac5519e

Comment 3 Fedora Update System 2020-11-18 03:15:15 UTC
FEDORA-EPEL-2020-ca1ac5519e has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-ca1ac5519e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2020-12-03 02:09:30 UTC
FEDORA-EPEL-2020-ca1ac5519e has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.