Bug 185196 - Postfix: MySQL support
Postfix: MySQL support
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-11 11:42 EST by Jim Bolino
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-13 04:48:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Bolino 2006-03-11 11:42:28 EST
Description of problem:
Postfix (in its current configuration) lacks mysql support. 

Version-Release number of selected component (if applicable):
2.2.2-2

How reproducible:
Always

Steps to Reproduce:
1. Yum install postfix
2. edit main.cf -> alias_maps = mysql:/etc/postfix/mysql-aliases.cf
3. restart
  
Actual results:
- postfix/smtpd[1422]: fatal: unsupported dictionary type: mysql

Expected results:
- no errors

Additional info:
When i download the src.rpm and edit the postfix.spec -> %define MYSQL 1
It all works fine. I was wondering why you choose to disable it in the first 
place?
Comment 1 Thomas Woerner 2006-03-13 04:48:27 EST
Mysql support is disabled in postfix, because it would require to install mysql
for all users even in minimal installs, if the user decided to use postfix. 
The option is in there to make it easier for me or others to activate mysql
support later on.

I am sorry for this, but it is not possible to build mysql support as a module
for postfix right now; therefore it has to be disabled.
Comment 2 Jim Bolino 2006-03-13 20:52:58 EST
I'm not really familair with the policy about dependicies, but i was wondering 
why one package has mysql support enabled by default, and an other hasn't.

for example: Dovecot, has mysql support enabled by default, so in your eyes 
that would also be a unnecessary dependency.

And I don’t think you should install Postfix if you are trying to do a small 
install, because sendmail is already installed, and is much smaller.

In my opinion, most people who choose to install postfix as their MTA, do that 
because there is much more and better documentation available for postfix. 
Especially things like: connecting with sql databases.

If it was possible to compare the amount of people running postfix/sendmail 
with sql, you would see that postfix+sql is the winner.

Note You need to log in before you can comment on or make changes to this bug.