Bug 185198 - ipw2200 needs several rounds of loading/unloading before it works
ipw2200 needs several rounds of loading/unloading before it works
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-11 12:11 EST by Horst H. von Brand
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.6.16-1.2131_FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-15 21:23:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Relevant contents of /var/log/messages (2.61 KB, text/plain)
2006-03-11 12:11 EST, Horst H. von Brand
no flags Details
Contents of /var/log/messages from start until working ipw2200 (30.31 KB, application/octet-stream)
2006-03-31 20:33 EST, Horst H. von Brand
no flags Details

  None (edit)
Description Horst H. von Brand 2006-03-11 12:11:54 EST
Description of problem:
To get ipw2200 to work, I had to insert/remove/insert the module by hand several
times, each time with different error messages.

Version-Release number of selected component (if applicable):
kernel-2.6.15-1.2038_FC5

How reproducible:
Always

Steps to Reproduce:
1. ifup eth1
2.
3.
  
Actual results:
eth1 is not present; need several rounds of rmmod/modprobe until it is found and
works

Expected results:
Working the first time.

Additional info:
Comment 1 Horst H. von Brand 2006-03-11 12:11:54 EST
Created attachment 125998 [details]
Relevant contents of /var/log/messages
Comment 2 Horst H. von Brand 2006-03-11 13:59:59 EST
Fiexed in 2.6.15-1.2041_FC5
Comment 3 Horst H. von Brand 2006-03-12 10:08:02 EST
Sorry, wrong. Still the same with 2.6.15-1.2041_FC5
Comment 4 John W. Linville 2006-03-13 08:45:50 EST
Have you downloaded and installed the version 2.4 firmware from here? 
 
   http://ipw2200.sourceforge.net/firmware.php 
 
Please do so and post the results here...thanks! 
Comment 5 Horst H. von Brand 2006-03-13 12:40:45 EST
Yep, that's the firmware I have. Created a local RPM for it based on the ATrpms one.

In any case, the card wouldn't work at all with older/newer firmware...
Comment 6 Horst H. von Brand 2006-03-13 18:05:38 EST
BTW, it might be that the "works fine with 2.6.15-1.2041_FC5" (#2 above) was due
to restarting the machine, in which case I presume the firmware stays loaded in
the card. It broke again after a cold boot.
Comment 7 Horst H. von Brand 2006-03-15 21:07:03 EST
Now (2.6.15-1.2054_FC5) configuring the interface works fine, but it seems that
the communication to the access point breaks down after a few hundred KiB
transferred.
Comment 8 Horst H. von Brand 2006-03-26 19:37:08 EST
Yet again (2.6.16-1.2083_FC6), similar sypmthoms: Need to load/unload/load the
ipw2200 to get it to work. The first time it associates and gets an IP, but then
the network breaks down.
Comment 9 Dave Jones 2006-03-28 18:17:22 EST
latest driver needs 3.0 firmware. try that ?
Comment 10 Horst H. von Brand 2006-03-29 12:27:54 EST
I do have firmware 3.0. If I hadn't, the card wouldn't work at all, doesn't it?

Just checked, the firmware file at intel hasn't changed, and the (self-built)
RPM for firmware 3.0 is installed and checks out fine with rpm -V.

BTW, I see the same trouble (on and off) with the vanilla kernel git versions.
Comment 11 Horst H. von Brand 2006-03-30 08:36:02 EST
Again, kernel-2.6.16-1.2102_FC6. "ifup eth1" claims ipw2200 isn't present, two
or three rounds of "rmmod ipw2200; modprobe ipw2200" make it work
Comment 12 John W. Linville 2006-03-30 09:32:26 EST
FWIW, I sent some email to the ipw2200 maintainers to see if they have any 
suggestions... 
Comment 13 Chuyee 2006-03-30 10:14:23 EST
Can you attach the dmesg during the "rmmod ipw2200; modprobe ipw2200" ?
Comment 14 Horst H. von Brand 2006-03-31 20:33:34 EST
Created attachment 127167 [details]
Contents of /var/log/messages from start until working ipw2200

Kernel 2.6.16-1.2106_FC6

I had to do 2 rounds of "rmmod ipw2200; modprobe ipw2200" until it didn't claim
the card isn't present, and then some more until it worked...

I looked the attached messages over, the file ipw2200-bss.fw it claims isn't
there or is broken is definitely there, and the same than the one at the Intel
site.
Comment 15 Horst H. von Brand 2006-04-01 20:19:58 EST
FYI, the vanilla kernel as of yesterday (20060331) from git works OK.
Comment 16 Chuyee 2006-04-02 22:29:55 EDT
This looks more likely a firmware hotplug/udev bug.
Comment 17 Horst H. von Brand 2006-04-04 22:04:16 EDT
Now (kernel-2.6.16-1.2118_FC6) it works. Or did once. Let's see...
Comment 18 Horst H. von Brand 2006-04-05 10:55:04 EDT
Two cold boots, "ifup eth1" works the first time. Let's look for a third...
Comment 19 Horst H. von Brand 2006-04-05 17:57:57 EDT
Tried now (kernel-2.6.16-1.2121_FC6). Needed to "rmmod ipw2200; insmod ipw2200"
to get it to work, ifup eth1 claimed the card wasn't present.
Comment 20 Horst H. von Brand 2006-04-15 21:23:03 EDT
Now it works the first time (2.6.16-1.2131_FC6, and some earlier ones). Have
tried several times, it seems the problem is really gone.

Note You need to log in before you can comment on or make changes to this bug.