Bug 18521 - perlcc doesn't work
Summary: perlcc doesn't work
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-06 13:15 UTC by sgiesecke
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-06 13:15:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sgiesecke 2000-10-06 13:15:09 UTC
When trying to compile any perl script, I get the following output as I run
perlcc:

--------------------------------------------------------------------------------
Compiling test.pl:
--------------------------------------------------------------------------------
Making C(test.pl.c) for test.pl!
perl -I/usr/lib/perl5/5.6.0/i386-linux -I/usr/lib/perl5/5.6.0
-I/usr/lib/perl5/site_perl/5.6.0/i386-linux
-I/usr/lib/perl5/site_perl/5.6.0 -I/usr/lib/perl5/site_perl -I. -MB::Stash
-c  test.pl
perl -I/usr/lib/perl5/5.6.0/i386-linux -I/usr/lib/perl5/5.6.0
-I/usr/lib/perl5/site_perl/5.6.0/i386-linux
-I/usr/lib/perl5/site_perl/5.6.0 -I/usr/lib/perl5/site_perl -I.
-MO=C,-umain,-uattributes,-uDB test.pl
Starting compile
Walking tree
Prescan
Saving methods
Bootstrap attributes test.pl
Writing output
Loaded B
Loaded IO
Loaded Fcntl
test.pl syntax OK
Compiling C(test) for test.pl!
perl -I/usr/lib/perl5/5.6.0/i386-linux -I/usr/lib/perl5/5.6.0
-I/usr/lib/perl5/site_perl/5.6.0/i386-linux
-I/usr/lib/perl5/site_perl/5.6.0 -I/usr/lib/perl5/site_perl -I.
/tmp/test.pl.tst
gcc -fno-strict-aliasing  -I/usr/lib/perl5/5.6.0/i386-linux/CORE -o test
test.pl.c   -L/usr/local/lib -L/usr/lib/perl5/5.6.0/i386-linux/CORE -lperl
-lnsl -ldl -lm -lc -lcrypt /usr/lib/perl5/5.6.0/i386-linux/auto/IO/IO.so
/usr/lib/perl5/5.6.0/i386-linux/auto/Fcntl/Fcntl.so
/tmp/ccBoUpbE.o: In function `xs_init':
/tmp/ccBoUpbE.o(.text+0x326d): undefined reference to `boot_DynaLoader'
collect2: ld returned 1 exit status
ERROR: In compiling code for test.pl.c !

In this case test.pl contained only one line:
exit

RPM version is perl-5.6.0-9

Comment 1 Crutcher Dunnavant 2001-04-19 19:15:10 UTC
right. first, perlcc is very experimental, so this is low priority.

but, perl 5.6.1 doesnt have this problem.
try the perl rpms available at:

http://people.redhat.com/crutcher/perl/

please note that these are not supported, and we cannot move to these untill we
are ready to go to red hat 8.0 (because of binarry compatability problems).


Note You need to log in before you can comment on or make changes to this bug.