Bug 1852150 - lua-event fails to build (with Lua 5.4) (and hence fails to install): nothing provides perl(:MODULE_COMPAT_5.30.1) needed by perl-Monotone-1.1-34.fc32.x86_64 [NEEDINFO]
Summary: lua-event fails to build (with Lua 5.4) (and hence fails to install): nothing...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lua-event
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Robert Scheck
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1851313
Blocks: F33FTBFS
TreeView+ depends on / blocked
 
Reported: 2020-06-29 20:16 UTC by Igor Raits
Modified: 2020-08-07 20:55 UTC (History)
2 users (show)

Fixed In Version: lua-event-0.4.6-6.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-07 20:55:18 UTC
Type: ---
redhat-bugzilla: needinfo? (igor.raits)


Attachments (Terms of Use)

Description Igor Raits 2020-06-29 20:16:22 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (ignatenkobrain@fedoraproject.org).

Your package (lua-event) Fails To Install in Fedora 33:

can't install lua-event:
  - nothing provides lua(abi) = 5.3 needed by lua-event-0.4.6-4.fc32.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/rawhide-gating/multi-builds/

Thanks!

Comment 1 Miro Hrončok 2020-06-30 14:37:47 UTC
DEBUG util.py:621:  Error: 
DEBUG util.py:621:   Problem: package ikiwiki-3.20200202.3-3.fc33.noarch requires perl(Monotone), but none of the providers can be installed
DEBUG util.py:621:    - conflicting requests
DEBUG util.py:621:    - nothing provides perl(:MODULE_COMPAT_5.30.1) needed by perl-Monotone-1.1-34.fc32.x86_64

Comment 2 Igor Raits 2020-07-07 05:33:28 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 3 Robert Scheck 2020-07-07 11:54:04 UTC
Igor, the issue is currently outside of lua-event as Miro kindly pointed out. Nevertheless I'm setting it to ASSIGNED hereby.

Comment 4 Igor Raits 2020-08-03 19:31:20 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (ignatenkobrain@fedoraproject.org).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 33.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.