Bug 18522 - i810 Video Adapter Flicker/Redraw issues
i810 Video Adapter Flicker/Redraw issues
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-06 09:26 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-10 07:15:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-06 09:26:05 EDT
Installed Red Hat 7, default KDE workstation on a DELL GX100, Celeron 566,
128 mb RAM, i810 chipset.  Graphical install finds video adapter and Dell
E550 monitor with no problem, but there is condierable flicker and slow
redraw including occaisional blackouts to the screen, to the point of
giving me quite a headache while trying to find a workaround.  To insure it
was not hardware failure I tryed it on 3 different boxes that have no video
issues with Windows NT 4 or Red Hat 6.2 upgraded to 2.2.16-3, and tried
several monitors (Princeton Ultra Scan 52, Viewsonic A70).  Tried "NoAccel"
option from the XFree86 info regarding the i810 chipset, but did not help.
Comment 1 Need Real Name 2000-10-09 17:13:57 EDT
Found a passable fix for desktop apps, run "Xconfigurator --nodri" and it runs
rock solid, but obviously no acceleration.
Comment 2 Alan Cox 2000-10-14 18:41:18 EDT
The --nodri option only turns off the 3D acceleration features.
Comment 3 Need Real Name 2000-10-15 19:17:25 EDT
Yes, I understand that, but it has solved the problem, the machines are quite
usable now, tried this on four different boxes and the flicker problem is gone. 
Don't know what the relationship to the DRI module and the driver is, but
something in that relationship seems to cause the problem.
Comment 4 giulioo 2000-12-10 07:15:44 EST
I had the very same problem, tried commenting out 'Load  "dri"' from XF86Config-
4 as suggested above and the problems went away.
I had "flashing" everywhere, the most annoying were gnome control center
(flashing at every new selection of an element of the left tree) and netscape 
mail composer (every single character I typed made the white background of the 
email to turn black and then white very quickly).
[ i810, PhilipsBrilliance150P ]


Note You need to log in before you can comment on or make changes to this bug.