Bug 1852443 - RH-Operator e2e test should not fail fast
Summary: RH-Operator e2e test should not fail fast
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.z
Assignee: Evan Cordell
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On: 1850709
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-30 12:37 UTC by OpenShift BugZilla Robot
Modified: 2020-08-17 20:05 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-17 20:05:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github operator-framework operator-lifecycle-manager pull 1614 None open [release-4.5] Bug 1852443: Remove failfast from operator e2e test 2020-08-04 20:19:47 UTC
Red Hat Product Errata RHBA-2020:3330 None None None 2020-08-17 20:05:42 UTC

Description OpenShift BugZilla Robot 2020-06-30 12:37:33 UTC
+++ This bug was initially created as a clone of Bug #1850709 +++

Description of problem:

RH-operator metric and install tests should not fail fast. Some operators may fail to install, all the rest of the operators should still be tested.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from bsong@redhat.com on 2020-06-24 19:26:12 UTC ---

waiting for https://github.com/openshift/release/pull/9901 to merge first and then we can backport https://github.com/operator-framework/operator-lifecycle-manager/pull/1592

Comment 3 Jian Zhang 2020-08-07 07:56:40 UTC
No found the tests are failing fast. Verify it.

Comment 6 errata-xmlrpc 2020-08-17 20:05:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.6 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3330


Note You need to log in before you can comment on or make changes to this bug.