Bug 1852565 - Change the etcd health check timeout in kube-apiserver to 10s
Summary: Change the etcd health check timeout in kube-apiserver to 10s
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.z
Assignee: Abu Kashem
QA Contact: Ke Wang
URL:
Whiteboard:
Depends On: 1852058
Blocks: 1850057
TreeView+ depends on / blocked
 
Reported: 2020-06-30 17:42 UTC by Abu Kashem
Modified: 2020-07-21 10:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1852058
Environment:
Last Closed: 2020-07-21 10:31:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 25222 0 None closed UPSTREAM: <carry>: Bug 1852565: change etcd health check timeout to 10s 2020-08-10 20:54:34 UTC
Red Hat Product Errata RHBA-2020:2913 0 None None None 2020-07-21 10:31:41 UTC

Description Abu Kashem 2020-06-30 17:42:06 UTC
+++ This bug was initially created as a clone of Bug #1852058 +++

+++ This bug was initially created as a clone of Bug #1852056 +++

Description of problem:
Currently the etcd health check timeout inside kube-apiserver is hard coded to `2s`. This is very aggressive, change the timeout to 10s

This should help the upgrade failures we are seeing in Azure - https://bugzilla.redhat.com/show_bug.cgi?id=1852047

Comment 3 Ke Wang 2020-07-10 07:48:20 UTC
Checked the PR which only has one change from 2 seconds to 10 seconds. No test action from QE. Thus could move to VERIFIED.

Confirmed the PR has been landed to the latest OCP 4.4 payload, see below,

$ oc adm release info --commits registry.svc.ci.openshift.org/ocp/release:4.4.0-0.nightly-2020-07-10-004502 |grep origin
  hyperkube                                      https://github.com/openshift/origin                                         b8568b30f485f5f37f0cdb14f803b629610248a2

$ git log --date local --pretty="%h %an %cd - %s" b8568b3 | grep '#25222'
b8568b30f4 OpenShift Merge Robot Thu Jul 9 15:33:38 2020 - Merge pull request #25222 from tkashem/etcd-healthcheck-4.4

Comment 5 errata-xmlrpc 2020-07-21 10:31:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2913


Note You need to log in before you can comment on or make changes to this bug.