Bug 185270 - trouble with mount and reiserfs
trouble with mount and reiserfs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-12 21:02 EST by Randy Cushman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-30 13:15:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Cushman 2006-03-12 21:02:56 EST
Description of problem:
I installed Fedora Core 5 test 3 to a reiserfs root partition, now the mount
command is behaving pecularly.  'mount' by itself generates no output.  Attempts
to mount additional reiserfs partitions results in the error "mount: Operation
not supported".  Attempts to mount ext3 partitions generate the message "can't
link lock file /etc/mtab~: Permission denied (use -n flag to override)", but the
mount is successful.

Version-Release number of selected component (if applicable):
mount (util-linux 2.13-pre6)

How reproducible:
completely

Steps to Reproduce:
1. Install FC5t3 using "linux acpi=off reiserfs" to reiserfs root partition
2. attempt to execute commands below
3.
  
Actual results:

[root@liz64 ~]# mount
[root@liz64 ~]# cat /etc/fstab
/dev/sda9               /                       reiserfs defaults        1 1
/dev/sda5               /mnt/sda5               reiserfs defaults        1 1
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0
/dev/sda6               swap                    swap    defaults        0 0
[root@liz64 ~]# mount /dev/sda5
mount: Operation not supported
[root@liz64 ~]# mount -t ext3 /dev/sda10 /mnt/sda10
can't link lock file /etc/mtab~: Permission denied (use -n flag to override)
[root@liz64 ~]# ls /etc/mtab~
ls: /etc/mtab~: No such file or directory
[root@liz64 ~]# mount
[root@liz64 ~]# ls /mnt/sda10
bin   dev  halt  lib    lost+found  misc  net  proc  sbin     srv  tmp  var
boot  etc  home  lib64  media       mnt   opt  root  selinux  sys  usr
[root@liz64 ~]# ls /mnt/sda5
[root@liz64 ~]#
     
Expected results:
'mount' lists filesystems currently mounted
other mount commands succeed without generating errors

Additional info:
Comment 1 Karel Zak 2006-03-13 03:34:29 EST
Do you have mounted /proc? Can you check you /var/log/audit/audit.log (or
aureport output)? A lot of problems has been fixed in the latests selinux-policy
releases. Please, try update too.
Comment 2 Randy Cushman 2006-03-13 20:16:09 EST
/proc appears to be mounted (the contents of the directory is similar to what I
see when I boot another linux partition).

I disabled selinux after determining it was inhibiting user root from running
graphical configuration tools.  /var/log/audit/audit.log has a length of zero. 
aureport lists all zeroes.

The tool "up2date" is not installed.  This is consistent with my understanding
that updates are not provided for Fedora test cores.
Comment 3 Karel Zak 2006-03-27 04:01:51 EST
The right tool for Fedora updates is the "yum" command. Can you reproduce this
bug  on final (updated) Fedora Core 5?
Comment 4 Randy Cushman 2006-03-30 13:15:41 EST
I cannot reproduce the issue with the final Fedora Core 5.
Comment 5 Randy Cushman 2006-03-30 13:16:41 EST
thanks

Note You need to log in before you can comment on or make changes to this bug.