Bug 185272 - anaconda doesn't handle all PE sizes in UI
anaconda doesn't handle all PE sizes in UI
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-03-12 21:40 EST by Dax Kelson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-01 17:44:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The whole debug info generated by Anaconda (68.47 KB, text/plain)
2006-03-12 21:40 EST, Dax Kelson
no flags Details

  None (edit)
Description Dax Kelson 2006-03-12 21:40:23 EST
Description of problem:
March 11th 2006 rawhide tree.

On my laptop I have an FC4 install on LVM. I created a new 15GB LV "rawhide" to
install to.

When I booted the installer, I chose "custom layout".

On the disk druid screen I could see my "VG0" volume group, my FC4 LVs and the
"rawhide" LV I created. I highlighted the "rawhide" LV and then clicked the Edit
button intending to assign "/" to it with the ext3 format.

However, when I clicked Edit, Anaconda threw up a trackback. I tried the "remote
host" option, but it seemed to hang, so I switched to tty2 and ran scp manually
to xfer the crash data.

Here first part of the crash data, I'll attach the whole crash data.

Traceback (most recent call last):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1046, in editCb
    self.editLVMVolumeGroup(vgrequest)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1126, in editLVMVolumeGroup
    origvgrequest, isNew)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 1001, in __init__
    (self.lvmlist, sw) = self.createAllowedLvmPartitionsList(self.availlvmparts,
self.origvgrequest.physicalVolumes, self.partitions, origvgrequest.getPreExisting())
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 326, in
createAllowedLvmPartitionsList
    pesize = int(self.peCombo.get_active_value())
TypeError: int() argument must be a string or a number

Local variables in innermost frame:
used: 1
uid: 4
sw: <gtk.ScrolledWindow object (GtkScrolledWindow) at 0xb7b2f504>
partname: hda5
request: Existing Part Request -- mountpoint: None uniqueID: 4
  type: physical volume (LVM)  format: None  badblocks: None
  device: hda5 drive: hda  primary: None
  size: 128675.008301  grow: 0  maxsize: None
  start: 29529423  end: 293055839  migrate: None    fslabel: None  origfstype:
physical volume (LVM)
  bytesPerInode: 4096  options: 'None'
self: <lvm_dialog_gui.VolumeGroupEditor instance at 0xb736960c>
preexist: 1
partlist: <WideCheckList object (GtkTreeView) at 0xb7b2f34c>
alllvmparts: [(4, 128675L, 1)]
part: (4, 128675L, 1)
partitions: <partitions.Partitions instance at 0xb73552ac>
reqlvmpart: [4]
store: <gtk.TreeStore object (GtkTreeStore) at 0xb7b2f324>
size: 128675.008301
Comment 1 Dax Kelson 2006-03-12 21:40:23 EST
Created attachment 126012 [details]
The whole debug info generated by Anaconda
Comment 2 Dax Kelson 2006-03-12 21:49:47 EST
Another clue?

This crash is 100% reproducible. On another try, when I got to the disk druid
screen before clicking Edit and causing the crash, I went to tty2 and ran the
"lvm " command.

A lvdisplay showed all my LVs, but none where "available". Is that expected?

I ran vgchange and activated everything.

I went back to disk druid and clicked Edit. The crash still happened.
Comment 3 Jeremy Katz 2006-03-13 14:08:59 EST
Is there anything "strange" abour your volume group?  I'm not reproducing this
here in a quick test.

Can you run 
 lvm vgdisplay --options vg_name,vg_size,vg_extent_size 
and show the output?
Comment 4 Dax Kelson 2006-03-13 14:38:07 EST
I don't think there is anything strange, other than the fact that in my FC4
install started out without LVM, but when I got a new laptop hard drive, I
booted to FC4 rescue mode and created the LVM by hand, then "cp -a" my FC4 data
back and then rebuilt my initrd.

So I migrated my FC4 to LVM (which has been working fine).

From inside my running FC4, here is the output of vgdisplay:

lvm> vgdisplay --options vg_name,vg_size,vg_extent_size
  Incompatible options selected
lvm> vgdisplay
  --- Volume group ---
  VG Name               VG0
  System ID
  Format                lvm2
  Metadata Areas        1
  Metadata Sequence No  5
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                4
  Open LV               3
  Max PV                0
  Cur PV                1
  Act PV                1
  VG Size               125.62 GB
  PE Size               128.00 MB
  Total PE              1005
  Alloc PE / Size       656 / 82.00 GB
  Free  PE / Size       349 / 43.62 GB
  VG UUID               MTYLg4-n3IU-SrSW-576g-TIZ9-Wks2-C3obqC

lvm>

Do you want this same output from tty2 during a rawhide install?
Comment 5 Jeremy Katz 2006-03-13 15:00:38 EST
What's happening is that your PE size is 128M which is above what we generally
show in the UI.

For FC5 final, I've just bumped the "what we show" up to 128M.  For FC6, we
should make this handle the case where someone does something we don't expect
and just add that value to the list.

Note You need to log in before you can comment on or make changes to this bug.