Bug 1852790 - Opening Terminal tab of a node which has disk pressure will got js error and blank page
Summary: Opening Terminal tab of a node which has disk pressure will got js error and ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.z
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1852689
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-01 10:26 UTC by Jakub Hadvig
Modified: 2020-09-08 10:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-08 10:54:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
Show pod error on terminal (108.83 KB, image/png)
2020-08-21 07:32 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5876 None closed [release-4.5] Bug 1852790: When node disk is under pressure NodeTerminalError should show pod's status message 2020-08-31 10:49:18 UTC
Red Hat Product Errata RHBA-2020:3510 None None None 2020-09-08 10:54:25 UTC

Description Jakub Hadvig 2020-07-01 10:26:50 UTC
This bug was initially created as a copy of Bug #1852689

I am copying this bug because: 



Description of problem:
When a node has DiskPressure, on Node lists page we will show 'Disk Pressure', viewing its Terminal tab will got js error and blank page

Version-Release number of selected component (if applicable):
    4.5.0-0.nightly-2020-06-30-003734

How reproducible:
Always

Steps to Reproduce:
1. When some node has DiskPressure(see screenshot `Node Diskpressure`), visit its Terminal tab


Actual results:
1. page becomes blank and js error are reported
Oh no! Something went wrong.
TypeError
Description:

c.containerStatuses is undefined

Component Trace: 
in E
    in Unknown
    in Unknown
    in w
    in Unknown
    in w
    in Unknown
    in t
    in t
    in div
    in Data
    in StatusBox
    in div
    in Unknown
    in Unknown
    in Unknown
    in Unknown
    in w
    in Unknown
    in w
    in Unknown
    in s
    in DetailsPage
    in Unknown
    in c
    in Unknown
    in w
    in t
    in t
    in div
    in div
    in section
    in d
    in Unknown
    in w
    in w
    in div
    in div
    in f
    in p
    in div
    in p
    in NotificationDrawer
    in Unknown
    in w
    in main
    in div
    in b
    in component
    in t
    in t
    in t
    in t

Stack Trace: 
E@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/node-detail-chunk-de1e2371d8729e185a92.min.js:1:6234
Fo@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:136:55337
ha@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:136:62378
Ks@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:136:99519
Bs@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:136:84010
Ns@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:136:81035
Ds@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:136:79608
di/<@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:136:41759
t.unstable_runWithPriority@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:144:3878
li@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:136:41488
di@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:136:41707
pi@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:136:41640
Is@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:136:79935
notify@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:23:75934
a</t.notifyNestedSubs@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:23:75503
f</n.notifySubscribers@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:65:2428
a</t.handleChangeWrapper@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:23:75571
v@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:17:122529
b/</</<@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/main-chunk-5bae70193ec819545f9a.min.js:1:89823
dispatch@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/vendors~main-chunk-ad08a18433ffab6d64a8.min.js:17:126016
l/<@https://console-openshift-console.apps.tbuskeypub-1.qe.azure.devcluster.openshift.com/static/main-chunk-5bae70193ec819545f9a.min.js:1:84212

Expected results:
1. Node terminal is opened without error

Additional info:

Comment 2 Jakub Hadvig 2020-07-31 14:45:54 UTC
Will fix next sprint.

Comment 5 Yadan Pei 2020-08-21 07:31:31 UTC
when a node is at 'Disk Pressure', opening its Terminal we will get a message below instead of blank page
Danger alert:The debug pod failed. Pod The node had condition: [DiskPressure]. 

Verified on 4.5.0-0.nightly-2020-08-20-235458

Comment 6 Yadan Pei 2020-08-21 07:32:01 UTC
Created attachment 1712129 [details]
Show pod error on terminal

Comment 8 errata-xmlrpc 2020-09-08 10:54:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.8 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3510


Note You need to log in before you can comment on or make changes to this bug.