Bug 18528 - XFree86 memory mapping problem on S3 Trio 64/32
Summary: XFree86 memory mapping problem on S3 Trio 64/32
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-06 14:20 UTC by Wouter Liefting
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-25 14:57:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of installation process (deleted)
2001-05-31 15:28 UTC, Wouter Liefting
no flags Details
Screenshot of installation process (deleted)
2001-05-31 15:29 UTC, Wouter Liefting
no flags Details

Description Wouter Liefting 2000-10-06 14:20:34 UTC
On my test system (P100, S3Trio 64/32) the memory mapping of XFree86 seems to be wrong. Somewhere halfway through the screen there 
is some sort of inverse overlap, where (coincidentally) the KDE buttons for the virtual desktop are displayed twice, next to each other 
horizontally. To the right of this overlap, all bits seem to be skewed to the right. If you put an xterm on this overlap, the xterm is stretched 
horizontally and text appears twice. (Wish I had a photograph to show you what I mean.)

This does not affect the mouse pointer itself however, resulting in the strange situation that when I click somewhere, the button that is about 1" 
to the right of the mouse cursor is pressed.

Same system, RH62 has no problems at all. I haven't tried downgrading to the RH62 supplied XFree86 packages (yet).

Comment 1 Mike A. Harris 2001-05-25 14:57:21 UTC
Please attach a screenshot so I can see what it looks like.  You can make
one with ksnapshot in KDE or screenshooter in GNOME or GIMP, etc..

I also need a copy of your X server logs and config files via the link below.

Comment 2 Mike A. Harris 2001-08-22 02:30:46 UTC
File attachments are either totally broken, or were not properly
flagged as images, so I can't view them by clicking on them.
Please reattach easily viewable screenshots. Also attach X server
logs and configs.


Comment 3 Mike A. Harris 2001-08-22 02:32:30 UTC
Please reopen bug when the information is made available that was
requested.

Comment 4 Wouter Liefting 2001-08-27 08:29:47 UTC
I lost the original photos of the screens (screenshots don't work while installing) so I would need to borrow a digital camera again to make new shots. 
But since the bug only shows up in 7.0 and we're currently using 7.1, it's not worth the trouble for me. So don't bother to reopen the bug.

BTW I verified that bug can be fixed by downgrading to the XFree86_SVGA that was supplied with RH 6.2 (strangely enough, this is the same version 
number only a new revision...)


Note You need to log in before you can comment on or make changes to this bug.