Bug 185284 - pup is unable to use gnome proxy settings + error in french translation
pup is unable to use gnome proxy settings + error in french translation
Status: CLOSED DUPLICATE of bug 185309
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-13 03:33 EST by stef
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-17 18:23:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
capture of pup running showing translation trouble (221.07 KB, image/png)
2006-03-13 03:34 EST, stef
no flags Details

  None (edit)
Description stef 2006-03-13 03:33:04 EST
Description of problem:

when launching pup in the applications menu, pup start but don't find any
repository, if launched from console after a "export http_proxy=http://proxy" it
works fine.
Also, in french translation when running the package information recovery, it
shows a window saying only "R" (see screenshot)

Version-Release number of selected component (if applicable):

FC5test3 - pirut-1.0.1-1

How reproducible:
always 

Steps to Reproduce:
1.launch pup from the gnome Applications menu
2.launch pup from console after exporting the http_proxy settings
3.
  
Actual results:
can't retrieve repository informations

Expected results:
use the gnome proxy settings

Additional info:
Comment 1 stef 2006-03-13 03:34:53 EST
Created attachment 126022 [details]
capture of pup running showing translation trouble
Comment 2 Jeremy Katz 2006-03-13 13:46:43 EST
Does it work if you set the proxy config in the yum config?
Comment 3 stef 2006-03-17 03:18:54 EST
(In reply to comment #2)
> Does it work if you set the proxy config in the yum config?

no it doesn't. However the trouble is more complex :

1) if you do this in a terminal
# export http_proxy=http://proxy:8080
# pup

pup will work fine

2) if you edit yum.conf and add the line  proxy=http://proxy:8080

-pup fails to retrieve informations when launched from the gnome-applications menu
-pup works when started in a console
Comment 4 Electron 2006-03-26 13:04:44 EST
First dialog box show "R" in French is "Corrected and uploaded to CVS"
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=184153
Comment 5 Jeremy Katz 2006-04-12 12:37:58 EDT
Can you try the yum package at
http://people.redhat.com/~katzj/yum-2.6.0-2.noarch.rpm and see if it helps the
proxy issue?
Comment 6 stef 2006-04-13 07:18:37 EDT
(In reply to comment #5)
> Can you try the yum package at
> http://people.redhat.com/~katzj/yum-2.6.0-2.noarch.rpm and see if it helps the
> proxy issue?

Tryed, Yum now works !
Even doing 'sudo yum upgrade' in a terminal is okay.
However Pup is still not happy : "Unable to retrieve update information"

Comment 7 Jeremy Katz 2006-04-17 18:23:30 EDT
Aha, I see what's going on.  Marking a dupe of the main bug I'm going to use for
tracking this so that I don't have to juggle a few of these

*** This bug has been marked as a duplicate of 185309 ***
Comment 8 David Lawrence 2006-06-27 21:33:44 EDT
Moving component to pirut. Sorry for the spam.

Note You need to log in before you can comment on or make changes to this bug.