Bug 1852856 - perl-Template-Toolkit depends on mod_perl, which eventually installs httpd
Summary: perl-Template-Toolkit depends on mod_perl, which eventually installs httpd
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: perl-Template-Toolkit
Version: epel8
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-01 13:04 UTC by Martin VanWinkle
Modified: 2020-07-17 01:17 UTC (History)
4 users (show)

Fixed In Version: perl-Template-Toolkit-2.29-4.el8
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-17 01:17:20 UTC
Type: Bug


Attachments (Terms of Use)

Description Martin VanWinkle 2020-07-01 13:04:22 UTC
Description of problem:

In epel-x86_64 8:
* perl-Template-Toolkit depends on perl(Apache::Util)
* perl(Apache::Util) is provided by mod_perl
* mod_perl depends on http-mmn
* http-mmn depends on httpd



Version-Release number of selected component (if applicable):

perl-Template-Toolkit-2.29-3.el8.x86_64

How reproducible:

1.  Install perl-Template-Toolkit
2.  httpd gets installed as a dependency

Expected results:

Installing perl-Template-Toolkit should not install a web server.

Additional info:

This wasn't an issue in EL7.

Comment 1 Fedora Update System 2020-07-01 17:26:28 UTC
FEDORA-EPEL-2020-b01f134c3e has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-b01f134c3e

Comment 2 Fedora Update System 2020-07-02 01:28:01 UTC
FEDORA-EPEL-2020-b01f134c3e has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-b01f134c3e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2020-07-17 01:17:20 UTC
FEDORA-EPEL-2020-b01f134c3e has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.