Bug 185295 - kwin does not resized of window properly
kwin does not resized of window properly
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-artwork (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-13 08:05 EST by ritz
Modified: 2013-03-05 22:45 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:46:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the bug (109.76 KB, image/png)
2006-03-13 08:12 EST, ritz
no flags Details
bug screenshot (119.52 KB, image/png)
2006-03-13 08:28 EST, ritz
no flags Details
testcase program (22.81 KB, text/plain)
2006-03-13 08:30 EST, ritz
no flags Details

  None (edit)
Description ritz 2006-03-13 08:05:12 EST
Description of problem:
kwin does not resized window properly

Version-Release number of selected component (if applicable):
kdebase-3.1.3-5.9-i386

How reproducible:
very reproducible

Steps to Reproduce:
1. Run the program attached below
2. Change kicker size to any option shown, but tiny
3. click on bug, and cycle across window

screen shot attached
and application source 

Actual results:
window size is smaller than it should be

Expected results:
Window's should not have any scrollbar

Additional info:
Was not able to replicate the same on metacity on gnome
or kwin on gnome.
Comment 1 ritz 2006-03-13 08:12:01 EST
Created attachment 126034 [details]
Screenshot of the bug
Comment 2 ritz 2006-03-13 08:28:45 EST
Created attachment 126036 [details]
bug screenshot
Comment 3 ritz 2006-03-13 08:30:38 EST
Created attachment 126037 [details]
testcase program

To compile
cc -o phzformresize1 -L/usr/X11R6/lib -lXm -lXt -lX11 phzformresize1.c
Comment 5 Ngo Than 2006-03-14 07:49:01 EST
It looks like a bug in Bluecurve theme. Does this bug still appear if
you change the "Window Decoration" (KDE2)?
Comment 6 ritz 2006-03-16 05:24:40 EST
i Was not able to reproduce in "KDE 2" Window decoration 
Comment 49 RHEL Product and Program Management 2007-10-19 14:46:28 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.