Bug 185321 - For php-pear-1.4.8, better template.spec
For php-pear-1.4.8, better template.spec
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php-pear (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
: 176658 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-13 13:19 EST by Remi Collet
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-17 07:47:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
php-pear-1.4.8-template.patch (2.71 KB, patch)
2006-03-13 13:19 EST, Remi Collet
no flags Details | Diff
php-pear-1.4.8-package.patch (11.37 KB, patch)
2006-03-13 13:20 EST, Remi Collet
no flags Details | Diff

  None (edit)
Description Remi Collet 2006-03-13 13:19:28 EST
Description of problem:

php-pear-1.4.8 is available.
I work a little on it.

I know php-pear-PEAR-Command-packaging is on the road, but i think template.spec
use by "pear makerpm" still usefull and could be improved.

1/ "--soft" on (un)install to allow upgrade on same version (when a new RPM
release is build for the same version).

2/ delete .channels, .depdb and .debdblock

3/ in %file : 
remplacing / by %{peardir}/*
adding @rpm_xml_dir@/@package@.xml
 
I give you the 2 patch i've make :
- 1 for template.spec 
- 1 for Package.php (using yours from php-pear-1.4.6

Hope that's help.
Comment 1 Remi Collet 2006-03-13 13:19:28 EST
Created attachment 126059 [details]
php-pear-1.4.8-template.patch
Comment 2 Remi Collet 2006-03-13 13:20:16 EST
Created attachment 126060 [details]
php-pear-1.4.8-package.patch
Comment 3 Joe Orton 2006-03-14 09:52:28 EST
Can this go upstream?  I'd rather not deviate so much from upstream here.  I'm
going to dupe bug 176658 against this since it's a subset.
Comment 4 Joe Orton 2006-03-14 09:52:51 EST
*** Bug 176658 has been marked as a duplicate of this bug. ***
Comment 5 Tim Jackson 2006-03-14 10:15:03 EST
This should go upstream, yes. Remi, your suggestions are good; please do file a
bug upstream at http://pear.php.net/bugs. NB that at least (2) is fixed in
PEAR_Command_Packaging. The version in PEAR core is not going to be fixed as
there's no point in splitting it out otherwise.

I will do a php-pear-PEAR-Command-Packaging soon.
Comment 6 Remi Collet 2006-03-15 13:04:38 EST
See : http://pear.php.net/bugs/bug.php?id=7129
Comment 7 Tim Jackson 2006-03-15 18:28:26 EST
1. See bug #185423 for php-pear-PEAR-Command-Packaging
2. All items are fixed upstream
3. Joe, I suggest marking this bug CLOSED WONTFIX
Comment 8 Joe Orton 2006-05-17 07:47:35 EDT
Should all be fixed in 1.4.9, or not appropriate.

Note You need to log in before you can comment on or make changes to this bug.