Bug 185329 - RFE: provide -l, --list or equivalent cmdline option to provide list of user mountable devices
RFE: provide -l, --list or equivalent cmdline option to provide list of user ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-mount (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-13 14:46 EST by Jef Spaleta
Modified: 2009-03-06 19:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 19:48:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2006-03-13 14:46:15 EST
Description of problem:
In the Desktop model, a user can rely on nautilus to provide accurate
information as to which devices are available to be mounted by listing them in
the Computer window.

Previously, with fstab-sync a user at the cmdline could do a quick cat of
/etc/fstab to see which devices and mountpoints existed as 'console owner'
mountable devices.

Currently with gnome-mount there is no obvious mechanism by which to discover
what devices,mountpoints, UID's are mountable  at the cmdline.  I would
appreciate it if gnome-mount could be extended so that I could run
gnome-mount --list  and get information as to which devices or UID's where
available for mounting and what type of device they were.. similar to the
information provided in nautilus's Computer window. Trying to parse lshal for
this list as a seperate step is unwieldy if not impossible for an mere mortal.

 
Or to phrase it in the form of a question.

How do you expect cmdline users who will be using gnome-mount figure out which
devices they can mount without resorting to trial and error? 

-jef
Comment 1 Matthew Miller 2007-04-06 14:36:43 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 2 Jef Spaleta 2007-04-06 14:49:43 EDT
nothing's changed in current development.

gnome-mount still doesn't provide a usable 'discoverability' feature that will
let non-desktop console owners what the mountable devices are as controlled by Hal.

Since gnome-mount is the primary gui AND cmdline tool which is meant to be used
for mounting user mountable devices as controlled through HAL, there really
really needs to be a way to use gnome-mount to list which devices/mounts are
mountable, instead of having to resort to lshal as a cmdline user.
Comment 3 Matthew Miller 2007-04-06 14:56:46 EDT
This seems like something that should be moved upstream. I'll move this to
devel, but really I think this should be reported with GNOME and marked
closed:upstream here.
Comment 4 Jon Stanley 2008-04-23 16:29:38 EDT
Adding FutureFeature keyword to RFE's.
Comment 5 Matthias Clasen 2009-03-06 19:48:04 EST
I'm going to close this as WONTFIX. 

Going forward, gnome-mount is being phased out in favour of gvfs-mount, which does already have a -l option

Note You need to log in before you can comment on or make changes to this bug.