Bug 18535 - XFree86 doesn't work when using loadlin and frame buffer
XFree86 doesn't work when using loadlin and frame buffer
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-06 10:56 EDT by Pasi Sjoholm
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-23 06:29:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pasi Sjoholm 2000-10-06 10:56:01 EDT
Sometimes I go to Win98 and play especially NHL-games and so on...
When I'm done with it I use loadlin.exe to boot back to Linux because I
don't want make a real boot every time. =)

So I boot linux kernel with loadlin.exe and everything goes ok but when I
try to start it says:

--cut--
(II) LoadModule: "vbe"
(II) Loading /usr/X11R6/lib/modules/libvbe.a
(II) Module vbe: vendor="The XFree86 Project"
        compiled for 4.0.1a, module version = 1.0.0
        ABI class: XFree86 Video Driver, version 0.2
(EE) ATI(0): unknown reason for exception
X86_IP:ffff X86_AX:4f00 X86_BX:0000 X86_CX:0000 X86_DX:0000 X86_SI:0000
X86_DI:1
000 X86_BP:0000 
X86_SP:00fa X86_CS:024f X86_SS:0030 X86_ES:0000 X86_DS:0040 X86_FS:0000
X86_GS:0
000 X86_EFLAGS:00033282 
stack at 0x000003fa:
00 00 60 00 00 32 f8 03 f8 02 e8 03 00 00 78 03 
code at 0x000124ef: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 
                    00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 
(EE) ATI(0): cannot continue
(EE) ATI(0): Unable to correctly retrieve adapter BIOS.
(II) UnloadModule: "ati"
(II) UnloadModule: "vbe"
(II) Unloading /usr/X11R6/lib/modules/libvbe.a
(II) UnloadModule: "ddc"
(II) Unloading /usr/X11R6/lib/modules/libddc.a
(II) UnloadModule: "int10"
(II) Unloading /usr/X11R6/lib/modules/linux/libint10.a
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
--cut--

cat /proc/fb
--cut--
0 ATY Mach64
--cut--

dmesg at boot...
--cut--
atyfb: 3D RAGE (GT) [0x4754 rev 0x41] 4M SDRAM, 14.31818 MHz XTAL, 170 MHz
PLL, 
67 Mhz MCLK
BUS_CNTL DAC_CNTL MEM_CNTL EXT_MEM_CNTL CRTC_GEN_CNTL DSP_CONFIG DSP_ON_OFF
73330040 8701200a 104210b7 15000001     02410200      00470553   02ac03d4
PLL cd d5 21 14 9a 03 fb e8 c4 00 00 e1 a6 1b 00 00
Console: switching to colour frame buffer device 80x30
fb0: ATY Mach64 frame buffer device on PCI
--cut--

With XFree4.0.0 this worked fine without any problem with same kernel
(2.2.17) and XFree4.0.1a is working too when I use LILO to boot up my
system but I can't get it into my head why loadlin.exe would be problem
when it never has been that before this.

I tried also compile XFree4.0.1a from src.rpm but it did have the same kind
of problem. So... I guess it is a bug. :(

with best regards,
Pasi Sjoholm
Comment 1 Pasi Sjoholm 2000-11-16 11:16:16 EST
Just tested this with my friend's computer and noticed this happens only with
GT-chip, because we both have also ATI-graphic card with VT-chip and it works
ok.
Comment 2 Mike A. Harris 2001-09-23 06:29:15 EDT
Does this problem still occur for you with whatever release you are
currently using?  If so, can you please provide updated info, and attach
your kernel "messages" logfile, X server log, and XF86Config-4 config
file using the link below.

Thanks.
Comment 3 Mike A. Harris 2001-10-31 22:19:15 EST
Closing bug.  You've indicated the system works when you use LILO,
which is our supported method of booting Linux.  Theoretically
LOADLIN should work also.  If it doesn't, use LILO instead.

Note You need to log in before you can comment on or make changes to this bug.