Bug 185354 - Please remove kdemultimedia requirement
Summary: Please remove kdemultimedia requirement
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-13 22:47 UTC by Julian Sikorski
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-14 13:09:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Julian Sikorski 2006-03-13 22:47:44 UTC
I find kdemultimedia requirement for amarok very inconvenient, mainly because it
contains 'junk' I don't really need (notaun, kscd, kaboodle, etc.). What is
more, arts plugin was removed from the player in beta2 as being obsolete, so is
there a reason to keep this dependency?
Other option would be to split kdemultimedia into applications and libs, so that
installing it won't be that 'painful'.

Regards,
JS

Comment 1 Aurelien Bompard 2006-03-14 08:33:19 UTC
I am currently rebuilding amarok for beta2 in extras, and since the arts engine
is gone it seems reasonable to remove the hardcoded dependecy on kdemultimedia.
Rex, does this seem right to you ?

Comment 2 Rex Dieter 2006-03-14 12:29:35 UTC
Yep, IMO, the hard-coded dependancy probably shouldn't ever have been there.  (-:

Comment 3 Rex Dieter 2006-03-14 12:45:16 UTC
While you're at it, you can change
desktop-file-install --vendor="fedora" --delete-original 
to
desktop-file-install --vendor=""

per recent discussions on the FE mailing list regarding vendor.  It only need be
set it not already done so (it is effectively already "kde" since it's using
applications/kde in this case).

Comment 4 Aurelien Bompard 2006-03-14 13:09:10 UTC
Done, thanks to both of you.


Note You need to log in before you can comment on or make changes to this bug.