Bug 185398 - objc ICE: in expand_expr_real_1, at expr.c:6604
objc ICE: in expand_expr_real_1, at expr.c:6604
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-14 07:22 EST by Axel Thimm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.1.0-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-07 02:33:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source from ICE (372.59 KB, text/plain)
2006-03-14 07:22 EST, Axel Thimm
no flags Details

  None (edit)
Description Axel Thimm 2006-03-14 07:22:09 EST
Description of problem:
Trying to build sope on FC4/i386 bails out with
NGActiveSocket.m:89: internal compiler error: in expand_expr_real_1, at expr.c:6604
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccVxgbBw.out file, please attach this to
your bugreport.
(the file is attached)

The lines around the error are:
     84 #if !defined(WIN32) || defined(__CYGWIN32__)
     85 
     86 + (BOOL)socketPair:(id<NGSocket>[2])_pair
inDomain:(id<NGSocketDomain>)_domain {
     87   int fds[2];
     88 
     89   _pair[0] = nil;
     90   _pair[1] = nil;


Version-Release number of selected component (if applicable):
gcc-objc-4.0.2-8.fc4
(also tried on rawhide with 4.1.0-3)

How reproducible:
always

Steps to Reproduce:
1.Try to build sope.
2.
3.
  
Actual results:
see ICE output above

Expected results:
Should build

Additional info:
o The sope framework requires building against an alternative libobj, maybe 
  that's the cause?
o Builds on FC4/x86_64
o Builds on RHL7.3-9, RHEL3/4, FC1-3 on both i386 and x86_64
o Same behaviour (x86_64 builds, i386 not) on rawhide

I don't speak any objc, so I can't dig any further or reduce the issue to a
minimal file. Please let me know how else I can help.

Thanks!
Comment 1 Axel Thimm 2006-03-14 07:22:10 EST
Created attachment 126096 [details]
Preprocessed source from ICE
Comment 3 Jakub Jelinek 2006-04-07 02:33:44 EDT
Should be fixed in gcc-4.1.0-6 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.