Bug 185419 - pango.modules file permissions
pango.modules file permissions
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pango (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
: Reopened
: 143486 188764 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-14 12:04 EST by Kevin Krafthefer
Modified: 2010-10-22 00:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-08 08:36:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Krafthefer 2006-03-14 12:04:18 EST
Description of problem:
the file pango.modules gets layed down with permission inherented from the
system's umask

Version-Release number of selected component (if applicable):
pango-1.6.0-9

How reproducible:
always

Steps to Reproduce:
1. set system umask to something other than default
2. rpm -ivh pango
3. check file permissions on pango.modules
  
Actual results:


Expected results:


Additional info:
Comment 1 Kevin Krafthefer 2006-03-14 12:05:25 EST
This change to the spec file fixes the problem:

# diff -rp pango.spec pango.spec.orig
*** pango.spec  2006-03-14 11:55:05.000000000 -0500
--- pango.spec.orig     2006-03-14 11:01:13.000000000 -0500
*************** rm -rf $RPM_BUILD_ROOT
*** 155,161 ****

  %post
  /sbin/ldconfig
! umask 0022
  # Deriving /etc/pango/$host location
  #
  # autoconf changes linux to linux-gnu
--- 155,161 ----

  %post
  /sbin/ldconfig
!
  # Deriving /etc/pango/$host location
  #
  # autoconf changes linux to linux-gnu
Comment 2 Matthias Clasen 2006-06-20 01:16:52 EDT
Reassigning pango bugs to Behdad.
Comment 3 Behdad Esfahbod 2006-07-27 17:53:55 EDT
*** Bug 143486 has been marked as a duplicate of this bug. ***
Comment 4 Behdad Esfahbod 2006-07-27 18:04:30 EDT
*** Bug 188764 has been marked as a duplicate of this bug. ***
Comment 7 RHEL Product and Program Management 2008-02-01 14:13:22 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 9 Tony Fu 2008-10-05 21:47:11 EDT
User krafthef@redhat.com's account has been closed
Comment 10 RHEL Product and Program Management 2008-12-18 01:47:04 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Note You need to log in before you can comment on or make changes to this bug.