Bug 1854200 - Default hooks dir is wrong and the needed (/etc/containers/oci/hooks.d/) was removed
Summary: Default hooks dir is wrong and the needed (/etc/containers/oci/hooks.d/) was ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.0
Assignee: Peter Hunt
QA Contact: MinLi
URL:
Whiteboard:
Depends On: 1853735
Blocks: 1847805
TreeView+ depends on / blocked
 
Reported: 2020-07-06 18:09 UTC by OpenShift BugZilla Robot
Modified: 2020-07-13 17:45 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:44:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1905 0 None closed [release-4.5] Bug 1854200: crio: correct hooks directory 2021-01-19 09:42:59 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:45:10 UTC

Comment 1 Peter Hunt 2020-07-06 19:32:55 UTC
note: this regression was introduced early in the 4.5 timeframe, and was not backported to 4.4.

Comment 4 MinLi 2020-07-07 04:21:56 UTC
verified in version: 4.5.0-0.nightly-2020-07-06-211538 

$ oc get mc 01-master-container-runtime -o yaml | grep  crio
path: /etc/crio/crio.conf.d/00-default

$ oc get mc 01-worker-container-runtime -o yaml | grep crio
path: /etc/crio/crio.conf.d/00-default

$ oc debug node/ip-10-0-149-109.us-east-2.compute.internal
Starting pod/ip-10-0-149-109us-east-2computeinternal-debug ...
To use host binaries, run `chroot /host`
Pod IP: 10.0.149.109
If you don't see a command prompt, try pressing enter.
sh-4.2# chroot /host 
sh-4.4# cat /etc/crio/crio.conf.d/00-default | grep -i hook
hooks_dir = [
    "/etc/containers/oci/hooks.d",
sh-4.4#

Comment 5 errata-xmlrpc 2020-07-13 17:44:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.