Bug 1854222 - Request conntrack race condition fixes backport into 8.2 kernel
Summary: Request conntrack race condition fixes backport into 8.2 kernel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RHCOS
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.0
Assignee: Micah Abbott
QA Contact: Michael Nguyen
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-06 19:28 UTC by Nick Stielau
Modified: 2020-07-13 17:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:44:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:45:10 UTC

Description Nick Stielau 2020-07-06 19:28:59 UTC
Tracking bug for work related to backporting conntrack race condition fixes into 8.2 kernel and pinned into OCP 4.5.

Comment 5 Steve Milner 2020-07-07 02:00:31 UTC
PR: https://github.com/openshift/installer/pull/3849

Comment 8 Micah Abbott 2020-07-08 13:31:30 UTC
The 8.2.z kernel BZ for the conntrack issue is https://bugzilla.redhat.com/show_bug.cgi?id=1851003

In that BZ, we see that the issue is marked resolved + verified in `kernel-4.18.0-193.11.1.el8_2`

```
$ oc image info --output json $(oc adm release info -a ~/openshift-cluster-installs/all-the-pull-secrets.json --image-for=machine-os-content quay.io/openshift-release-dev/ocp-release:4.5.0-rc.7-x86_64) | jq .config.config.Labels.version
"45.82.202007062333-0"
```

Booting up the RHCOS 45.82.202007062333-0

```
$ rpm-ostree status -b
State: idle
AutomaticUpdates: disabled
BootedDeployment:
* ostree://bcfae65a2ab0b4ab5afcd1c9f1cce30b300e5408b04fc8bdec51a143ab593d40
                   Version: 45.82.202007062333-0 (2020-07-06T23:37:07Z)
[core@cosa-devsh ~]$ rpm -q kernel
kernel-4.18.0-193.12.1.el8_2.x86_64
```

A newer kernel is present than the one in the 8.2.z BZ, so marking this VERIFIED against 4.5.0-rc.7

Comment 10 errata-xmlrpc 2020-07-13 17:44:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.