Bug 1854371 - Inkscape 1.0 breaks pdflatex
Summary: Inkscape 1.0 breaks pdflatex
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-07 10:20 UTC by Oliver Sampson
Modified: 2020-11-07 02:34 UTC (History)
4 users (show)

Fixed In Version: texlive-2019-21.fc32 texlive-2020-29.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-07 02:34:22 UTC
Type: Bug


Attachments (Terms of Use)

Description Oliver Sampson 2020-07-07 10:20:13 UTC
Description of problem:
Including inkscape 1.0 in Fedora breaks pdflatex

Version-Release number of selected component (if applicable):
inkscape-1.0-2.fc31

How reproducible:
Always.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
pdflatex calls inkscape when the svg package is included in a .tex file and an svg file (\includesvg{}) is included in the .tex file. pdflatex calls inkscape with the -z option (--without-gui) which has been removed in inkscape 1.0. The call to inkscape fails and the image is not included in the document.

Comment 1 Fedora Update System 2020-07-10 19:57:03 UTC
FEDORA-2020-b74983b351 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-b74983b351

Comment 2 Fedora Update System 2020-07-10 19:57:03 UTC
FEDORA-2020-f9d623c6a5 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-f9d623c6a5

Comment 3 Fedora Update System 2020-07-11 01:36:39 UTC
FEDORA-2020-f9d623c6a5 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-f9d623c6a5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-f9d623c6a5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2020-07-11 02:06:17 UTC
FEDORA-2020-b74983b351 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-b74983b351`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-b74983b351

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Oliver Sampson 2020-07-11 10:48:37 UTC
I just tested the update on my usecase (Kile->pdfLatex) in a .tex file with \usepackage{svg} and \includesvg{filename}. 

The following errors were reported:
! Package scrbase Error: unknown member `' at family `SVG'.

See the scrbase package documentation for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                  
l.10 \begin{document}
                     
ABD: EveryShipout initializing macros [1{/usr/share/texlive/texmf-dist/fonts/ma
p/pdftex/updmap/pdftex.map}]
! Undefined control sequence.
\svg@local@param@set ...lyOptions {SVG}{#1}\Ifstr 
                                                  {\svg@ink@format }{png}{\F...
l.40  \includesvg[width=10cm]{filename}
                                          
! Undefined control sequence.
\reserved@a ->\Ifstr 
                     {svg}{svg}
l.40  \includesvg[width=10cm]{filename}
                                          
! Undefined control sequence.
\svg@get@lastpage #1->\Ifstr 
                             {\svg@ink@format }{pdf}{\begingroup \@tempcnta ...
l.40  \includesvg[width=10cm]{filename}
                                          
(./svg-inkscape/filename_svg-tex.pdf_tex)

Comment 6 Tom "spot" Callaway 2020-07-13 20:37:59 UTC
Hm. When I do a simple test case:

*** test.tex ***

\documentclass{article}
\usepackage{svg}
\usepackage{amsmath}
\begin{document}

\begin{figure}[htbp]
  \centering
  \includesvg{image}
  \caption{svg image}
\end{figure}

\end{document}


*** EOF ***

With image.svg in the same directly, I can now run:

pdflatex --shell-escape test.tex

and it works properly.

I'm not sure what's failing for you now, but it's not related to the inkscape -z issue.

Comment 7 Fedora Update System 2020-07-14 13:36:54 UTC
FEDORA-2020-f9d623c6a5 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-f9d623c6a5

Comment 8 Fedora Update System 2020-07-14 13:37:24 UTC
FEDORA-2020-b74983b351 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-b74983b351

Comment 9 Fedora Update System 2020-07-15 01:48:06 UTC
FEDORA-2020-b74983b351 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-b74983b351`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-b74983b351

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2020-07-15 02:00:36 UTC
FEDORA-2020-f9d623c6a5 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-f9d623c6a5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-f9d623c6a5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2020-10-07 20:36:09 UTC
FEDORA-2020-f9d623c6a5 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 matthias.rambausek 2020-10-26 21:41:59 UTC
Problem still persists at least on my up-to-data Fedora 32 system. Are there some caches I am not aware of that need to be cleaned?

Comment 13 Tom "spot" Callaway 2020-10-27 15:19:27 UTC
Should not be, unless you've been installing things manually from CTAN or something.

Can you try the test case in comment #6 (be sure you have an "image.svg" in the same working directory)?

Comment 14 matthias.rambausek 2020-10-27 19:29:50 UTC
Unfortunately, it does not work (see below).
I did the test with an official and updated fedora32 podman image and on the native OS with identical results. 
(just to check whether some remaining from a CTAN texlive installation cause trouble)


Failing doc:

\documentclass{article}
\usepackage{svg}
\begin{document}

\begin{figure}
  no image, no cry
  \caption{no image}
\end{figure}

\end{document}

----------------------- output (text.log) ---------------------------------

This is pdfTeX, Version 3.14159265-2.6-1.40.20 (TeX Live 2019) (preloaded format=pdflatex 2020.10.27)  27 OCT 2020 19:21
entering extended mode
 restricted \write18 enabled.
 %&-line parsing enabled.
**test.tex
(./test.tex
LaTeX2e <2018-12-01>
(/usr/share/texlive/texmf-dist/tex/latex/base/article.cls
Document Class: article 2018/09/03 v1.4i Standard LaTeX document class
(/usr/share/texlive/texmf-dist/tex/latex/base/size10.clo
File: size10.clo 2018/09/03 v1.4i Standard LaTeX file (size option)
)
\c@part=\count80
\c@section=\count81
\c@subsection=\count82
\c@subsubsection=\count83
\c@paragraph=\count84
\c@subparagraph=\count85
\c@figure=\count86
\c@table=\count87
\abovecaptionskip=\skip41
\belowcaptionskip=\skip42
\bibindent=\dimen102
)
(/usr/share/texlive/texmf-dist/tex/latex/svg/svg.sty

LaTeX Warning: You have requested release `2020-02-02' of LaTeX,
               but only release `2018-12-01' is available.

Package: svg 2020/06/23 v2.02h (include SVG pictures)
(/usr/share/texlive/texmf-dist/tex/generic/iftex/iftex.sty
Package: iftex 2013/04/04 v0.2 Provides if(tex) conditional for PDFTeX, XeTeX, 
and LuaTeX
)

LaTeX Warning: You have requested, on input line 66, version
               `2020/03/06' of package iftex,
               but only version
               `2013/04/04 v0.2 Provides if(tex) conditional for PDFTeX, XeTeX,
 and LuaTeX'
               is available.

(/usr/share/texlive/texmf-dist/tex/latex/koma-script/scrbase.sty
Package: scrbase 2019/02/01 v3.26b KOMA-Script package (KOMA-Script-independent
 basics and keyval usage)

(/usr/share/texlive/texmf-dist/tex/latex/graphics/keyval.sty
Package: keyval 2014/10/28 v1.15 key=value parser (DPC)
\KV@toks@=\toks14
)
(/usr/share/texlive/texmf-dist/tex/latex/koma-script/scrlfile.sty
Package: scrlfile 2019/02/01 v3.26b KOMA-Script package (loading files)
))

LaTeX Warning: You have requested, on input line 67, version
               `2020/04/19' of package scrbase,
               but only version
               `2019/02/01 v3.26b KOMA-Script package (KOMA-Script-independent 
basics and keyval usage)'
               is available.

(/usr/share/texlive/texmf-dist/tex/generic/oberdiek/pdftexcmds.sty
Package: pdftexcmds 2018/09/10 v0.29 Utility functions of pdfTeX for LuaTeX (HO
)

(/usr/share/texlive/texmf-dist/tex/generic/oberdiek/infwarerr.sty
Package: infwarerr 2016/05/16 v1.4 Providing info/warning/error messages (HO)
)
(/usr/share/texlive/texmf-dist/tex/generic/oberdiek/ifluatex.sty
Package: ifluatex 2016/05/16 v1.4 Provides the ifluatex switch (HO)
Package ifluatex Info: LuaTeX not detected.
)
(/usr/share/texlive/texmf-dist/tex/generic/oberdiek/ltxcmds.sty
Package: ltxcmds 2016/05/16 v1.23 LaTeX kernel commands for general use (HO)
)
(/usr/share/texlive/texmf-dist/tex/generic/oberdiek/ifpdf.sty
Package: ifpdf 2018/09/07 v3.3 Provides the ifpdf switch
)
Package pdftexcmds Info: LuaTeX not detected.
Package pdftexcmds Info: \pdf@primitive is available.
Package pdftexcmds Info: \pdf@ifprimitive is available.
Package pdftexcmds Info: \pdfdraftmode found.
)

LaTeX Warning: You have requested, on input line 68, version
               `2019/11/24' of package pdftexcmds,
               but only version
               `2018/09/10 v0.29 Utility functions of pdfTeX for LuaTeX (HO)'
               is available.

(/usr/share/texlive/texmf-dist/tex/latex/trimspaces/trimspaces.sty
Package: trimspaces 2009/09/17 v1.1 Trim spaces around a token list
)
(/usr/share/texlive/texmf-dist/tex/latex/graphics/graphicx.sty
Package: graphicx 2017/06/01 v1.1a Enhanced LaTeX Graphics (DPC,SPQR)

(/usr/share/texlive/texmf-dist/tex/latex/graphics/graphics.sty
Package: graphics 2017/06/25 v1.2c Standard LaTeX Graphics (DPC,SPQR)

(/usr/share/texlive/texmf-dist/tex/latex/graphics/trig.sty
Package: trig 2016/01/03 v1.10 sin cos tan (DPC)
)
(/usr/share/texlive/texmf-dist/tex/latex/graphics-cfg/graphics.cfg
File: graphics.cfg 2016/06/04 v1.11 sample graphics configuration
)
Package graphics Info: Driver file: pdftex.def on input line 99.

(/usr/share/texlive/texmf-dist/tex/latex/graphics-def/pdftex.def
File: pdftex.def 2018/01/08 v1.0l Graphics/color driver for pdftex
))
\Gin@req@height=\dimen103
\Gin@req@width=\dimen104
)

LaTeX Warning: You have requested, on input line 70, version
               `2019/11/30' of package graphicx,
               but only version
               `2017/06/01 v1.1a Enhanced LaTeX Graphics (DPC,SPQR)'
               is available.

(/usr/share/texlive/texmf-dist/tex/latex/tools/shellesc.sty
Package: shellesc 2016/06/07 v0.02a unified shell escape interface for LaTeX
Package shellesc Info: Restricted shell escape enabled on input line 69.
)

LaTeX Warning: You have requested, on input line 71, version
               `2019/11/08' of package shellesc,
               but only version
               `2016/06/07 v0.02a unified shell escape interface for LaTeX'
               is available.

! Undefined control sequence.
l.480 \ifxetex
              \else\ifpdf\else
? X

Comment 15 Tom "spot" Callaway 2020-10-28 15:15:03 UTC
Well, that's rather nasty and I can reproduce it there.

The good news is that Fedora 33 does not seem to have that issue. The bad news is that fixing it in Fedora 32 probably requires bringing the rest of TeXLive 2020 with it. Oh well, in for a penny, in for a pound.

Comment 16 Tom "spot" Callaway 2020-10-28 15:16:07 UTC
To be clear, I do _NOT_ plan to bring TL2020 to Fedora 31. I realize this leaves Fedora 31 broken for this scenario, but the cost of this change there is just too high.

Comment 17 matthias.rambausek 2020-10-28 16:12:29 UTC
'Good' to hear that I did not mess my system, but I see the trouble...

Well, I for my part moved to a fedora 33 toolbox container on my fedora 32 system until I'll do the full upgrade. Works fine even using texstudio and inkscape from the toolbox! (but I had at some point to relink /etc/resolv.conf since fedora 32 and fedora 33 have different /etc/resolv.conf locations...)

Comment 18 Fedora Update System 2020-10-29 15:58:12 UTC
FEDORA-2020-79b39cd581 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-79b39cd581

Comment 19 Fedora Update System 2020-10-30 01:31:08 UTC
FEDORA-2020-79b39cd581 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-79b39cd581`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-79b39cd581

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 20 Fedora Update System 2020-11-07 02:34:22 UTC
FEDORA-2020-79b39cd581 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.