Bug 1854596 - Updating terraform plugin SDK breaks azure
Summary: Updating terraform plugin SDK breaks azure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: John Hixson
QA Contact: Etienne Simard
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-07 18:13 UTC by John Hixson
Modified: 2020-10-27 16:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:12:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 3852 0 None closed Bug 1854596: vendor: bump terraform-provider-azure to version v2.17.0 2020-10-23 14:37:44 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:13:06 UTC

Description John Hixson 2020-07-07 18:13:18 UTC
Description of problem (please be detailed as possible and provide log
snippests):

The AWS terraform provider was recently updated to v2.67.0 in PR https://github.com/openshift/installer/pull/3837to fix bug https://bugzilla.redhat.com/show_bug.cgi?id=1844320, which in turn required the terraform plugin SDK to be updated to v1.14.0, which ended up causing the Azure terraform provider to have some internal conflicts. 

Does this issue impact your ability to continue to work with the product
(please explain in detail what is the user impact)?

Yes, Azure installation is no longer possible.

Is there any workaround available to the best of your knowledge?

No. 

Rate from 1 - 5 the complexity of the scenario you performed that caused this
bug (1 - very simple, 5 - very complex)?

1.

Can this issue reproducible?

Yes. 

Steps to Reproduce:
1. openshift-install create cluster
2. Azure + normal options
3. Profit!


Actual results:

level=error
level=error msg="Error: Internal validation of the provider failed! This is always a bug"
level=error msg="with the provider itself, and not a user issue. Please report"
level=error msg="this bug:"
level=error
level=error msg="3 errors occurred:"
level=error msg="\t* resource azurerm_key_vault_certificate: ConflictsWith: days_before_expiry configuration block reference (certificate_policy.0.lifetime_action.0.trigger.0.lifetime_percentage) can only be used with TypeList and MaxItems: 1 configuration blocks"
level=error msg="\t* resource azurerm_virtual_machine_scale_set: ConflictsWith: managed_disk_type configuration block reference (storage_profile_os_disk.vhd_containers) can only be used with TypeList and MaxItems: 1 configuration blocks"
level=error

Expected results:

A successful installation.

Additional info:

https://github.com/terraform-providers/terraform-provider-azurerm/commit/68a2f63372ddc2af2cddcedcd762caa59e5dead9 addresses the updated SDK problem.

Comment 3 John Hixson 2020-07-07 18:34:53 UTC
PR: https://github.com/openshift/installer/pull/3852

Comment 6 John Hixson 2020-07-10 03:47:02 UTC
The PR for this has merged.

Comment 9 Etienne Simard 2020-07-10 16:36:13 UTC
Verified with: 4.6.0-0.nightly-2020-07-10-092830

Installation successful and no apparent issue discovered.

Comment 11 errata-xmlrpc 2020-10-27 16:12:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.