Bug 1854612 - vSphere UPI: Update icon on status "Provisioned as node" for new machines not going away
Summary: vSphere UPI: Update icon on status "Provisioned as node" for new machines not...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: 4.5.z
Assignee: Yadan Pei
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1854345 (view as bug list)
Depends On: 1854131
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-07 18:59 UTC by OpenShift BugZilla Robot
Modified: 2020-09-08 10:54 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-08 10:54:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
Provisioned as node green ok icon (102.45 KB, image/png)
2020-08-21 08:51 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5910 None closed [release-4.5] Bug 1854612: Machine's 'Provisioned as node' phase should use SuccessStatus component with GreenCheckCircl... 2020-09-09 08:50:34 UTC
Red Hat Product Errata RHBA-2020:3510 None None None 2020-09-08 10:54:25 UTC

Description OpenShift BugZilla Robot 2020-07-07 18:59:49 UTC
+++ This bug was initially created as a clone of Bug #1854131 +++

Hi,

if I create a Machine on vSphere that has joined the cluster than in my opinion it should not display a "refresh" icon (circle with arrows) but at least a checkmark.

https://github.com/openshift/okd/issues/245

Version: OKD 4.5 nightly

Expected: Checkmark Icon

Current: Update Icon (despite the Machine has successfully joined the cluster)

Thanks and greetings,

Josef

--- Additional comment from vrutkovs@redhat.com on 2020-07-06 15:03:10 UTC ---

Retargetted to 4.6, so that later it could be cloned to 4.5

Comment 1 Jakub Hadvig 2020-07-08 11:02:59 UTC
*** Bug 1854345 has been marked as a duplicate of this bug. ***

Comment 6 Yadan Pei 2020-08-21 08:51:11 UTC
Created attachment 1712145 [details]
Provisioned as node green ok icon

1. create a upi on vSphere cluster and add new machines
2. after machines are successfully provisioned, it shows a green ok icon on Machines Phase

verified on 4.5.0-0.nightly-2020-08-20-235458

Comment 8 errata-xmlrpc 2020-09-08 10:54:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.8 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3510


Note You need to log in before you can comment on or make changes to this bug.